summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.txt13
-rw-r--r--Makefile15
-rw-r--r--README.txt2
-rw-r--r--VERSION.txt2
l---------bin/cnt1
l---------bin/cntsh1
-rwxr-xr-xbin/container-shell18
-rwxr-xr-xlib/container/list2
-rwxr-xr-xlib/container/stop12
-rw-r--r--share/doc/examples/cairon-backports.cfg2
-rw-r--r--share/doc/examples/jessie.cfg2
-rw-r--r--share/man/container-shell.1.txt14
-rw-r--r--share/man/container-stop.1.txt4
-rw-r--r--share/man/container-tools.7.txt2
-rwxr-xr-xshare/scripts/debconf.d/0003-debconf8
l---------share/scripts/debian1
l---------share/scripts/debian.d1
l---------share/scripts/progress-linux1
l---------share/scripts/progress-linux.d1
-rw-r--r--share/systemd/container-autostart.service2
20 files changed, 71 insertions, 33 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 3de75c9..55c178c 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,16 @@
+2016-04-15 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20160415.
+ * Fixing minor issues:
+ - build system
+ - container-shell program
+ - documentation
+ - systemd unit for container-autostart
+ * Updated debian default mirror from httpredir.debian.org to ftp.debian.org.
+
+ * Backward incompatible changes:
+ - container stop command option -k|--kill renamed to -f|--force for consistency
+
2016-04-01 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20160401.
diff --git a/Makefile b/Makefile
index 36dd8a1..0deb81e 100644
--- a/Makefile
+++ b/Makefile
@@ -77,8 +77,17 @@ install: build
fi; \
done
- ln -s container.1 $(DESTDIR)/usr/share/man/man1/cnt.1
- ln -s container-shell.1 $(DESTDIR)/usr/share/man/man1/cntsh.1
+ ln -sf container $(DESTDIR)/usr/bin/cnt
+ ln -sf container.1 $(DESTDIR)/usr/share/man/man1/cnt.1
+ ln -sf container-shell $(DESTDIR)/usr/bin/cntsh
+ ln -sf container-shell.1 $(DESTDIR)/usr/share/man/man1/cntsh.1
+
+ ln -sf debconf ${DESTDIR}/usr/share/$(SOFTWARE)/scripts/debian
+ ln -sf debconf.d ${DESTDIR}/usr/share/$(SOFTWARE)/scripts/debian.d
+ ln -sf container-create-debconf.1 $(DESTDIR)/usr/share/man/man1/container-create-debian.1
+ ln -sf debconf ${DESTDIR}/usr/share/$(SOFTWARE)/scripts/progress-linux
+ ln -sf debconf.d ${DESTDIR}/usr/share/$(SOFTWARE)/scripts/progress-linux.d
+ ln -sf container-create-debconf.1 $(DESTDIR)/usr/share/man/man1/container-create-progress-linux.1
mkdir -p $(DESTDIR)/lib/systemd/system
cp -r share/systemd/* $(DESTDIR)/lib/systemd/system
@@ -104,7 +113,9 @@ uninstall:
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/usr/share/man/man$${SECTION} || true; \
done
+ rm -f $(DESTDIR)/usr/bin/cnt
rm -f $(DESTDIR)/usr/share/man/man1/cnt.1
+ rm -f $(DESTDIR)/usr/bin/cntsh
rm -f $(DESTDIR)/usr/share/man/man1/cntsh.1
rm -rf $(DESTDIR)/usr/share/doc/$(SOFTWARE)
diff --git a/README.txt b/README.txt
index d264fea..3627c2d 100644
--- a/README.txt
+++ b/README.txt
@@ -34,7 +34,7 @@ systemd-nspawn.
3.2 Debian 8 (stretch) and newer
--------------------------------
- * sudo apt install open-infrastructure-container-tools
+ * sudo apt install container-tools
4. Development
diff --git a/VERSION.txt b/VERSION.txt
index 0029651..8460464 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20160401
+20160415
diff --git a/bin/cnt b/bin/cnt
deleted file mode 120000
index 50208cb..0000000
--- a/bin/cnt
+++ /dev/null
@@ -1 +0,0 @@
-container \ No newline at end of file
diff --git a/bin/cntsh b/bin/cntsh
deleted file mode 120000
index 38c4486..0000000
--- a/bin/cntsh
+++ /dev/null
@@ -1 +0,0 @@
-container-shell \ No newline at end of file
diff --git a/bin/container-shell b/bin/container-shell
index f40d711..4639537 100755
--- a/bin/container-shell
+++ b/bin/container-shell
@@ -43,7 +43,13 @@ Shell ()
OPTIONS="${@}"
case "${COMMAND}" in
- exit|logout|quit)
+ about)
+ man ${PROGRAM} || true
+
+ return
+ ;;
+
+ logout)
exit 0
;;
@@ -52,16 +58,17 @@ Shell ()
"")
echo
echo "The following ${PROGRAM} commands are available:"
+ echo
cd "/usr/lib/${SOFTWARE}/${PROGRAM}"
- ls
+ echo "$(for COMMAND in about logout *; do echo ${COMMAND}; done | sort)"
cd "${OLDPWD}"
return
;;
*)
- man container-${1}
+ man ${PROGRAM}-${1} || true
return
;;
@@ -74,14 +81,15 @@ Shell ()
echo "'${COMMAND}': no such ${PROGRAM} command" >&2
return
else
+ echo
"/usr/lib/${SOFTWARE}/${PROGRAM}/${COMMAND}" "${OPTIONS}" || true
fi
}
trap 'echo' EXIT HUP INT QUIT TERM
-echo "${PROGRAM}-shell $(${PROGRAM} version)"
-echo "Type \"help\" for more information."
+echo "${SOFTWARE} $(${PROGRAM} version)"
+echo "Type \"about\" or \"help\" for more information, \"logout\" to exit."
while true
do
diff --git a/lib/container/list b/lib/container/list
index 374942c..110e6ea 100755
--- a/lib/container/list
+++ b/lib/container/list
@@ -34,7 +34,7 @@ then
fi
# Run
-CONTAINERS="$(cd "${MACHINES}" && find -maxdepth 1 -type d -printf '%P\n' | sort)"
+CONTAINERS="$(cd "${MACHINES}" && find -maxdepth 1 -type d -and -not -name 'lost+found' -printf '%P\n' | sort)"
echo RUNNING
diff --git a/lib/container/stop b/lib/container/stop
index a11c155..cd3de10 100755
--- a/lib/container/stop
+++ b/lib/container/stop
@@ -24,8 +24,8 @@ MACHINES="/var/lib/machines"
Parameters ()
{
- LONG_OPTIONS="name:,kill"
- OPTIONS="n:,k"
+ LONG_OPTIONS="name:,force"
+ OPTIONS="n:,f"
PARAMETERS="$(getopt --longoptions ${LONG_OPTIONS} --name=${COMMAND} --options ${OPTIONS} --shell sh -- ${@})"
@@ -45,8 +45,8 @@ Parameters ()
shift 2
;;
- -k|--kill)
- KILL="true"
+ -f|--force)
+ FORCE="true"
;;
--)
@@ -64,7 +64,7 @@ Parameters ()
Usage ()
{
- echo "Usage: container ${COMMAND} -n|--name NAME [-k|--kill]" >&2
+ echo "Usage: container ${COMMAND} -n|--name NAME [-f|--force]" >&2
exit 1
}
@@ -93,7 +93,7 @@ case "${STATE}" in
;;
esac
-case "${KILL}" in
+case "${FORCE}" in
true)
MODE="terminate"
;;
diff --git a/share/doc/examples/cairon-backports.cfg b/share/doc/examples/cairon-backports.cfg
index 096cc5e..2fca922 100644
--- a/share/doc/examples/cairon-backports.cfg
+++ b/share/doc/examples/cairon-backports.cfg
@@ -17,7 +17,7 @@ container-tools cnt-debconf/archives multiselect cairon-security, cairon-updates
container-tools cnt-debconf/mirror string http://cdn.archive.progress-linux.org/packages
container-tools cnt-debconf/mirror-security string http://cdn.archive.progress-linux.org/packages
-container-tools cnt-debconf/parent-mirror string http://httpredir.debian.org/debian
+container-tools cnt-debconf/parent-mirror string http://ftp.debian.org/debian
container-tools cnt-debconf/parent-mirror-security string http://security.debian.org
container-tools cnt-debconf/archive-areas multiselect main, contrib, non-free
diff --git a/share/doc/examples/jessie.cfg b/share/doc/examples/jessie.cfg
index 509b09e..e9f9d46 100644
--- a/share/doc/examples/jessie.cfg
+++ b/share/doc/examples/jessie.cfg
@@ -14,7 +14,7 @@ container-tools cnt-debconf/architecture select auto
container-tools cnt-debconf/archives multiselect jessie-security, jessie-updates
#container-tools cnt-debconf/parent-archives multiselect
-container-tools cnt-debconf/mirror string http://httpredir.debian.org/debian
+container-tools cnt-debconf/mirror string http://ftp.debian.org/debian
container-tools cnt-debconf/mirror-security string http://security.debian.org
#container-tools cnt-debconf/parent-mirror string
diff --git a/share/man/container-shell.1.txt b/share/man/container-shell.1.txt
index 946f77e..9a2fdd8 100644
--- a/share/man/container-shell.1.txt
+++ b/share/man/container-shell.1.txt
@@ -39,7 +39,19 @@ container-tools provides the system integration for managing containers using sy
COMMANDS
--------
-All container commands are available, see container(1).
+All container commands are available, see container(1). Additionally, the following commands are specific to container-shell:
+
+*about:*::
+ shows introduction (manpage).
+
+*help:*::
+ shows available commands within the container-shell.
+
+*help COMMAND:*::
+ shows help (manpage) for a specific container command.
+
+*logout:*::
+ exits container-shell.
SEE ALSO
diff --git a/share/man/container-stop.1.txt b/share/man/container-stop.1.txt
index 8f368cf..5f8356d 100644
--- a/share/man/container-stop.1.txt
+++ b/share/man/container-stop.1.txt
@@ -44,7 +44,7 @@ The following container options are available:
*-n, --name='NAME'*::
Specify container name.
-*-k, --kill*::
+*-f, --force*::
Instead of running the proper shutdown sequence, terminate all processes of the container imediatly.
@@ -54,7 +54,7 @@ EXAMPLES
sudo container stop -n example.net
*Immediately stop example.net container:*::
- sudo container stop -n example.net -k
+ sudo container stop -n example.net -f
SEE ALSO
diff --git a/share/man/container-tools.7.txt b/share/man/container-tools.7.txt
index dc35030..d8e5ac9 100644
--- a/share/man/container-tools.7.txt
+++ b/share/man/container-tools.7.txt
@@ -54,7 +54,7 @@ SOURCE
DEBIAN 8 (STRETCH) AND NEWER
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- * sudo apt install open-infrastructure-container-tools
+ * sudo apt install container-tools
DEVELOPMENT
diff --git a/share/scripts/debconf.d/0003-debconf b/share/scripts/debconf.d/0003-debconf
index 2d0e3a9..03db192 100755
--- a/share/scripts/debconf.d/0003-debconf
+++ b/share/scripts/debconf.d/0003-debconf
@@ -298,7 +298,7 @@ Mirror ()
then
case "${MODE}" in
debian)
- db_set cnt-debconf/mirror http://httpredir.debian.org/debian
+ db_set cnt-debconf/mirror http://ftp.debian.org/debian
db_fset cnt-debconf/mirror seen false
;;
@@ -319,7 +319,7 @@ Mirror ()
then
case "${MODE}" in
debian)
- MIRROR="http://httpredir.debian.org/debian"
+ MIRROR="http://ftp.debian.org/debian"
;;
progress-linux)
@@ -391,7 +391,7 @@ Parent_mirror ()
then
case "${MODE}" in
progress-linux)
- db_set cnt-debconf/parent-mirror http://httpredir.debian.org/debian
+ db_set cnt-debconf/parent-mirror http://ftp.debian.org/debian
db_fset cnt-debconf/parent-mirror seen false
db_settitle cnt-debconf/title
@@ -412,7 +412,7 @@ Parent_mirror ()
then
case "${MODE}" in
progress-linux)
- PARENT_MIRROR="http://httpredir.debian.org/debian"
+ PARENT_MIRROR="http://ftp.debian.org/debian"
;;
*)
diff --git a/share/scripts/debian b/share/scripts/debian
deleted file mode 120000
index 7f725c5..0000000
--- a/share/scripts/debian
+++ /dev/null
@@ -1 +0,0 @@
-debconf \ No newline at end of file
diff --git a/share/scripts/debian.d b/share/scripts/debian.d
deleted file mode 120000
index 4ce36fe..0000000
--- a/share/scripts/debian.d
+++ /dev/null
@@ -1 +0,0 @@
-debconf.d \ No newline at end of file
diff --git a/share/scripts/progress-linux b/share/scripts/progress-linux
deleted file mode 120000
index 7f725c5..0000000
--- a/share/scripts/progress-linux
+++ /dev/null
@@ -1 +0,0 @@
-debconf \ No newline at end of file
diff --git a/share/scripts/progress-linux.d b/share/scripts/progress-linux.d
deleted file mode 120000
index 4ce36fe..0000000
--- a/share/scripts/progress-linux.d
+++ /dev/null
@@ -1 +0,0 @@
-debconf.d \ No newline at end of file
diff --git a/share/systemd/container-autostart.service b/share/systemd/container-autostart.service
index 1424ce8..076aa41 100644
--- a/share/systemd/container-autostart.service
+++ b/share/systemd/container-autostart.service
@@ -1,6 +1,6 @@
[Unit]
Description=container-tools automatic start
-After=syslog.target network.target
+After=network.target
[Service]
Type=oneshot