summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 35a6085..0cb6291 100644
--- a/Makefile
+++ b/Makefile
@@ -51,7 +51,7 @@ test:
# FIXME: fail hard on shellcheck once all issues are fixed
@echo -n "Checking with shellcheck... "
- @if [ -x /usr/bin/checkbashisms ]; \
+ @if [ -x /usr/bin/shellcheck ]; \
then \
for SCRIPT in $(SCRIPTS); \
do \
@@ -63,10 +63,10 @@ test:
fi
@echo " done."
-build: share/man/*.txt
+build: share/man/*.rst
$(MAKE) -C share/man
- sed -n '/^NAME/,$$p' share/man/$(SOFTWARE).7.txt > README.txt
+ sed -n '/^===/,$$p' share/man/$(SOFTWARE).7.rst > README.txt
install: build
mkdir -p $(DESTDIR)/etc/$(SOFTWARE)/config