summaryrefslogtreecommitdiffstats
path: root/share
diff options
context:
space:
mode:
Diffstat (limited to 'share')
-rw-r--r--share/bash-completion/container27
-rw-r--r--share/doc/examples/bullseye.cfg (renamed from share/doc/examples/buster.cfg)8
-rwxr-xr-xshare/doc/examples/container-images.sh2
-rw-r--r--share/doc/examples/fuchur-backports.cfg (renamed from share/doc/examples/engywuck-backports.cfg)8
-rwxr-xr-xshare/hooks/post-start.chown-nvidia.sh2
-rwxr-xr-xshare/hooks/pre-create.git-pull.sh9
-rwxr-xr-xshare/hooks/pre-start.unlink-console.sh5
-rw-r--r--share/logrotate/container2
-rw-r--r--share/man/Makefile2
-rw-r--r--share/man/compute-tools.7.txt2
-rw-r--r--share/man/container-auto.1.txt2
-rw-r--r--share/man/container-console.1.txt2
-rw-r--r--share/man/container-create-curl.1.txt8
-rw-r--r--share/man/container-create-debconf.1.txt8
-rw-r--r--share/man/container-create-debootstrap.1.txt2
-rw-r--r--share/man/container-create.1.txt2
-rw-r--r--share/man/container-enter.1.txt2
-rw-r--r--share/man/container-key.1.txt2
-rw-r--r--share/man/container-limit.1.txt2
-rw-r--r--share/man/container-list.1.txt2
-rw-r--r--share/man/container-log.1.txt2
-rw-r--r--share/man/container-move.1.txt2
-rw-r--r--share/man/container-remove.1.txt2
-rw-r--r--share/man/container-restart.1.txt2
-rw-r--r--share/man/container-run.1.txt2
-rw-r--r--share/man/container-shell.1.txt2
-rw-r--r--share/man/container-start.1.txt2
-rw-r--r--share/man/container-status.1.txt2
-rw-r--r--share/man/container-stop.1.txt2
-rw-r--r--share/man/container-top.1.txt2
-rw-r--r--share/man/container-version.1.txt2
-rw-r--r--share/man/container.1.txt12
-rwxr-xr-xshare/scripts/curl14
-rwxr-xr-xshare/scripts/curl.d/0001-debconf2
-rwxr-xr-xshare/scripts/debconf60
-rwxr-xr-xshare/scripts/debconf.d/0001-preseed-file7
-rwxr-xr-xshare/scripts/debconf.d/0002-preseed-debconf2
-rwxr-xr-xshare/scripts/debconf.d/0003-debconf16
-rwxr-xr-xshare/scripts/debootstrap4
39 files changed, 101 insertions, 137 deletions
diff --git a/share/bash-completion/container b/share/bash-completion/container
index 4e49cec..540f162 100644
--- a/share/bash-completion/container
+++ b/share/bash-completion/container
@@ -1,7 +1,6 @@
# bash-completion
#
-# Copyright (C) 2016 Andreas Kreuzer <andreas.kreuzer@open-infrastructure.net>
-# Copyright (C) 2016-2021 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+# Copyright (C) 2014-2021 Daniel Baumann <daniel.baumann@open-infrastructure.net>
#
# SPDX-License-Identifier: GPL-3.0+
#
@@ -16,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
_container()
{
@@ -63,13 +62,13 @@ _container()
create|cr)
case "${prev}" in
-n|--name)
- opts="$(cd /etc/open-infrastructure/container/debconf 2>/dev/null && ls *.cfg */*.cfg 2>/dev/null | sed -e 's|.*/||g' -e 's|.cfg$||g')"
+ opts="$(cd /etc/compute-tools/debconf 2>/dev/null && ls *.cfg */*.cfg 2>/dev/null | sed -e 's|.*/||g' -e 's|.cfg$||g')"
COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
return 0
;;
-s|--script)
- opts="$(cd /usr/share/open-infrastructure/container/scripts && find -maxdepth 1 -not -type d -and -not -name 'default' -and -not -name 'debconf' -and -not -name '*.d' -printf '%P\n' | sort)"
+ opts="$(cd /usr/share/compute-tools/scripts && find -maxdepth 1 -not -type d -and -not -name 'default' -and -not -name 'debconf' -and -not -name '*.d' -printf '%P\n' | sort)"
COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
return 0
;;
@@ -145,13 +144,13 @@ _container()
log)
case "${prev}" in
-d|--date)
- opts="$(if ls /var/log/open-infrastructure/container.log-*.gz > /dev/null 2>&1;
+ opts="$(if ls /var/log/compute-tools/container.log-*.gz > /dev/null 2>&1;
then \
- zcat /var/log/open-infrastructure/container.log-*.gz | awk '{ print $1 }' | sort -u; \
+ zcat /var/log/compute-tools/container.log-*.gz | awk '{ print $1 }' | sort -u; \
fi; \
- if [ -e /var/log/open-infrastructure/container.log ]; \
+ if [ -e /var/log/compute-tools/container.log ]; \
then \
- awk '{ print $1 }' /var/log/open-infrastructure/container.log | sort -u; \
+ awk '{ print $1 }' /var/log/compute-tools/container.log | sort -u; \
fi) \
today yesterday"
COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
@@ -159,13 +158,13 @@ _container()
;;
-n|--name)
- opts="$(if ls /var/log/open-infrastructure/container.log-*.gz > /dev/null 2>&1;
+ opts="$(if ls /var/log/compute-tools/container.log-*.gz > /dev/null 2>&1;
then \
- zgrep -E '(\-n|\-\-name) ' /var/log/open-infrastructure/container.log-*.gz | sed -e 's|.*-n ||' -e 's|.*--name ||' -e 's| .*$||' | sort -u; \
+ zgrep -E '(\-n|\-\-name) ' /var/log/compute-tools/container.log-*.gz | sed -e 's|.*-n ||' -e 's|.*--name ||' -e 's| .*$||' | sort -u; \
fi; \
- if [ -e /var/log/open-infrastructure/container.log ]; \
+ if [ -e /var/log/compute-tools/container.log ]; \
then \
- grep -E '(\-n|\-\-name) ' /var/log/open-infrastructure/container.log | sed -e 's|.*-n ||' -e 's|.*--name ||' -e 's| .*$||' | sort -u; \
+ grep -E '(\-n|\-\-name) ' /var/log/compute-tools/container.log | sed -e 's|.*-n ||' -e 's|.*--name ||' -e 's| .*$||' | sort -u; \
fi)"
COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
return 0
@@ -286,7 +285,7 @@ _container()
;;
*)
- local commands=$(cd /usr/lib/open-infrastructure/container 2>/dev/null && find * -type f -print)
+ local commands=$(cd /usr/libexec/container 2>/dev/null && find * -type f -print)
COMPREPLY=( $(compgen -W "${commands}" -- ${cur}) )
return 0
;;
diff --git a/share/doc/examples/buster.cfg b/share/doc/examples/bullseye.cfg
index cfc8595..044504e 100644
--- a/share/doc/examples/buster.cfg
+++ b/share/doc/examples/bullseye.cfg
@@ -1,4 +1,4 @@
-# example for automated Debian 10 (buster) based container creation
+# example for automated Debian 11 (bullseye) based container creation
# using: sudo container create -s debian
debconf debconf/priority select critical
@@ -9,16 +9,16 @@ compute-tools container/mode select debian
#compute-tools container/preseed-files string
#compute-tools container/include-preseed-files string
-compute-tools container/distribution select buster
+compute-tools container/distribution select bullseye
#compute-tools container/parent-distribution select
compute-tools container/architecture select auto
-compute-tools container/archives multiselect buster-security, buster-updates
+compute-tools container/archives multiselect bullseye-security, bullseye-updates
#compute-tools container/parent-archives multiselect
compute-tools container/mirror string https://deb.debian.org/debian
-compute-tools container/mirror-security string http://security.debian.org
+compute-tools container/mirror-security string https://security.debian.org
#compute-tools container/parent-mirror string
#compute-tools container/parent-mirror-security string
diff --git a/share/doc/examples/container-images.sh b/share/doc/examples/container-images.sh
index 7bb40b4..ede68b5 100755
--- a/share/doc/examples/container-images.sh
+++ b/share/doc/examples/container-images.sh
@@ -15,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
# Description: example for automated Debian base system container image creation
# Requires: debootstrap plzip xz-utils
diff --git a/share/doc/examples/engywuck-backports.cfg b/share/doc/examples/fuchur-backports.cfg
index 9ca0288..20cd127 100644
--- a/share/doc/examples/engywuck-backports.cfg
+++ b/share/doc/examples/fuchur-backports.cfg
@@ -1,4 +1,4 @@
-# example for automated Progress Linux 5+ (engywuck-backports) container creation
+# example for automated Progress Linux 6.99 (fuchur-backports) container creation
# using: sudo container create -s progress-linux
debconf debconf/priority select critical
@@ -9,19 +9,19 @@ compute-tools container/mode select progress-linux
#compute-tools container/preseed-files string
#compute-tools container/include-preseed-files string
-compute-tools container/distribution select engywuck-backports
+compute-tools container/distribution select fuchur-backports
#compute-tools container/parent-distribution select
compute-tools container/architecture select auto
-compute-tools container/archives multiselect engywuck-security, engywuck-updates, engywuck-extras, engywuck-backports, engywuck-backports-extras
+compute-tools container/archives multiselect fuchur-security, fuchur-updates, fuchur-extras, fuchur-backports, fuchur-backports-extras
#compute-tools container/parent-archives multiselect
compute-tools container/mirror string https://deb.progress-linux.org/packages
compute-tools container/mirror-security string https://deb.progress-linux.org/packages
compute-tools container/parent-mirror string https://deb.debian.org/debian
-compute-tools container/parent-mirror-security string http://security.debian.org
+compute-tools container/parent-mirror-security string https://security.debian.org
compute-tools container/archive-areas multiselect main, contrib, non-free
compute-tools container/parent-archive-areas multiselect main, contrib, non-free
diff --git a/share/hooks/post-start.chown-nvidia.sh b/share/hooks/post-start.chown-nvidia.sh
index e1ab35b..64c02cc 100755
--- a/share/hooks/post-start.chown-nvidia.sh
+++ b/share/hooks/post-start.chown-nvidia.sh
@@ -15,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
diff --git a/share/hooks/pre-create.git-pull.sh b/share/hooks/pre-create.git-pull.sh
index 823440f..744f955 100755
--- a/share/hooks/pre-create.git-pull.sh
+++ b/share/hooks/pre-create.git-pull.sh
@@ -15,14 +15,15 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
PROJECT="open-infrastructure"
+SOFTWARE="compute-tools"
PROGRAM="container"
-DIRECTORIES="/etc/${PROJECT}/${PROGRAM}/debconf /etc/${PROJECT}/${PROGRAM}/debconf/*/"
+DIRECTORIES="$(for DIRECTORY in $(find /etc/${SOFTWARE}/debconf/ -type d -name ".git"); do echo $(dirname ${DIRECTORY}); done | sort -uV)"
for DIRECTORY in ${DIRECTORIES}
do
@@ -30,9 +31,9 @@ do
then
echo "Updating ${DIRECTORY}..."
- if [ -e "/etc/${PROJECT}/${PROGRAM}.conf" ]
+ if [ -e "/etc/${SOFTWARE}.conf" ]
then
- . "/etc/${PROJECT}/${PROGRAM}.conf"
+ . "/etc/${SOFTWARE}.conf"
fi
DEBCONF_ID="${DEBCONF_ID:-HEAD}"
diff --git a/share/hooks/pre-start.unlink-console.sh b/share/hooks/pre-start.unlink-console.sh
index 3133a19..b44491e 100755
--- a/share/hooks/pre-start.unlink-console.sh
+++ b/share/hooks/pre-start.unlink-console.sh
@@ -15,14 +15,15 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
PROJECT="open-infrastructure"
+SOFTWARE="compute-tools"
PROGRAM="container"
-CONFIG="/etc/${PROJECT}/${PROGRAM}/config"
+CONFIG="/etc/${SOFTWARE}/config"
# Run
if grep -qs 'bind=.*/dev:/dev;' "${CONFIG}/${NAME}.conf"
diff --git a/share/logrotate/container b/share/logrotate/container
index 14599be..0722aa5 100644
--- a/share/logrotate/container
+++ b/share/logrotate/container
@@ -1,4 +1,4 @@
-/var/log/open-infrastructure/container.log {
+/var/log/compute-tools/container.log {
compress
create 0640 root adm
dateext
diff --git a/share/man/Makefile b/share/man/Makefile
index 1500b15..2ef1507 100644
--- a/share/man/Makefile
+++ b/share/man/Makefile
@@ -15,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
# Depends: asciidoc dblatex docbook-xsl libxml2-utils source-highlight
diff --git a/share/man/compute-tools.7.txt b/share/man/compute-tools.7.txt
index f8d9c76..e5f2c54 100644
--- a/share/man/compute-tools.7.txt
+++ b/share/man/compute-tools.7.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-TOOLS(7)
==================
diff --git a/share/man/container-auto.1.txt b/share/man/container-auto.1.txt
index 3ed4c56..ecb84b0 100644
--- a/share/man/container-auto.1.txt
+++ b/share/man/container-auto.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-START(1)
==================
diff --git a/share/man/container-console.1.txt b/share/man/container-console.1.txt
index 8f35a8d..59bb421 100644
--- a/share/man/container-console.1.txt
+++ b/share/man/container-console.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-CONSOLE(1)
====================
diff --git a/share/man/container-create-curl.1.txt b/share/man/container-create-curl.1.txt
index 1095103..e263092 100644
--- a/share/man/container-create-curl.1.txt
+++ b/share/man/container-create-curl.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-CREATE-CURL(1)
========================
@@ -83,10 +83,10 @@ FILES
-----
The following files are used:
-*/etc/open-infrastructure/container/config*::
+*/etc/compute-tools/config*::
Container configuration files.
-*/usr/share/open-infrastructure/container/scripts*::
+*/usr/share/compute-tools/scripts*::
Container creation scripts.
*/usr/share/doc/compute-tools*::
@@ -95,7 +95,7 @@ The following files are used:
*/var/lib/machines*::
Container directory.
-*/var/cache/open-infrastructure/container*::
+*/var/cache/container*::
Container cache directory.
diff --git a/share/man/container-create-debconf.1.txt b/share/man/container-create-debconf.1.txt
index f4092a0..a04dfaf 100644
--- a/share/man/container-create-debconf.1.txt
+++ b/share/man/container-create-debconf.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-CREATE-DEBOOTSTRAP(1)
===============================
@@ -114,10 +114,10 @@ FILES
-----
The following files are used:
-*/etc/open-infrastructure/container/config*::
+*/etc/compute-tools/config*::
Container configuration files.
-*/usr/share/open-infrastructure/container/scripts*::
+*/usr/share/compute-tools/scripts*::
Container creation scripts.
*/usr/share/doc/compute-tools*::
@@ -126,7 +126,7 @@ The following files are used:
*/var/lib/machines*::
Container directory.
-*/var/cache/open-infrastructure/container*::
+*/var/cache/container*::
Container cache directory.
*/tmp/compute-tools*::
diff --git a/share/man/container-create-debootstrap.1.txt b/share/man/container-create-debootstrap.1.txt
index 60f0a22..37d6414 100644
--- a/share/man/container-create-debootstrap.1.txt
+++ b/share/man/container-create-debootstrap.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-CREATE-DEBOOTSTRAP(1)
===============================
diff --git a/share/man/container-create.1.txt b/share/man/container-create.1.txt
index dcb0df4..c49ac9c 100644
--- a/share/man/container-create.1.txt
+++ b/share/man/container-create.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-CREATE(1)
===================
diff --git a/share/man/container-enter.1.txt b/share/man/container-enter.1.txt
index c8d7f3c..c7adc1e 100644
--- a/share/man/container-enter.1.txt
+++ b/share/man/container-enter.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-CONSOLE(1)
====================
diff --git a/share/man/container-key.1.txt b/share/man/container-key.1.txt
index 2b54d78..e6c1553 100644
--- a/share/man/container-key.1.txt
+++ b/share/man/container-key.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-KEY(1)
================
diff --git a/share/man/container-limit.1.txt b/share/man/container-limit.1.txt
index 5f1ca30..12d76cd 100644
--- a/share/man/container-limit.1.txt
+++ b/share/man/container-limit.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-LIMIT(1)
==================
diff --git a/share/man/container-list.1.txt b/share/man/container-list.1.txt
index 4016b87..4b3df3a 100644
--- a/share/man/container-list.1.txt
+++ b/share/man/container-list.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-LIST(1)
=================
diff --git a/share/man/container-log.1.txt b/share/man/container-log.1.txt
index c30b37a..b503d42 100644
--- a/share/man/container-log.1.txt
+++ b/share/man/container-log.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-LOG(1)
================
diff --git a/share/man/container-move.1.txt b/share/man/container-move.1.txt
index fef0bce..5c9475c 100644
--- a/share/man/container-move.1.txt
+++ b/share/man/container-move.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-REMOVE(1)
===================
diff --git a/share/man/container-remove.1.txt b/share/man/container-remove.1.txt
index 0975168..50ad861 100644
--- a/share/man/container-remove.1.txt
+++ b/share/man/container-remove.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-REMOVE(1)
===================
diff --git a/share/man/container-restart.1.txt b/share/man/container-restart.1.txt
index 2a4dfa8..afc4581 100644
--- a/share/man/container-restart.1.txt
+++ b/share/man/container-restart.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-RESTART(1)
====================
diff --git a/share/man/container-run.1.txt b/share/man/container-run.1.txt
index b46ebf8..593e1a7 100644
--- a/share/man/container-run.1.txt
+++ b/share/man/container-run.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-RUN(1)
================
diff --git a/share/man/container-shell.1.txt b/share/man/container-shell.1.txt
index 03f2185..ce5c13c 100644
--- a/share/man/container-shell.1.txt
+++ b/share/man/container-shell.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER(1)
============
diff --git a/share/man/container-start.1.txt b/share/man/container-start.1.txt
index 2b7b919..bc0c946 100644
--- a/share/man/container-start.1.txt
+++ b/share/man/container-start.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-START(1)
==================
diff --git a/share/man/container-status.1.txt b/share/man/container-status.1.txt
index 86820df..e74b8e5 100644
--- a/share/man/container-status.1.txt
+++ b/share/man/container-status.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-STATUS(1)
===================
diff --git a/share/man/container-stop.1.txt b/share/man/container-stop.1.txt
index 9eab1c4..dc36bb9 100644
--- a/share/man/container-stop.1.txt
+++ b/share/man/container-stop.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-STOP(1)
=================
diff --git a/share/man/container-top.1.txt b/share/man/container-top.1.txt
index 367be1b..295f51b 100644
--- a/share/man/container-top.1.txt
+++ b/share/man/container-top.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-TOP(1)
================
diff --git a/share/man/container-version.1.txt b/share/man/container-version.1.txt
index 6549d02..4f625f8 100644
--- a/share/man/container-version.1.txt
+++ b/share/man/container-version.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER-VERSION(1)
====================
diff --git a/share/man/container.1.txt b/share/man/container.1.txt
index d7ad339..7edc1f4 100644
--- a/share/man/container.1.txt
+++ b/share/man/container.1.txt
@@ -13,7 +13,7 @@
// GNU General Public License for more details.
//
// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
CONTAINER(1)
============
@@ -104,7 +104,7 @@ FILES
-----
The following files are used:
-*/etc/open-infrastructure/container*::
+*/etc/compute-tools/container*::
Container configuration files.
*/usr/bin/container*, */usr/bin/cnt*::
@@ -113,22 +113,22 @@ The following files are used:
*/usr/bin/container-shell*, */usr/bin/cntsh*::
Container shell program.
-*/usr/lib/open-infrastructure/container*::
+*/usr/libexec/container*::
Container commands.
-*/usr/share/open-infrastructure/container*::
+*/usr/share/compute-tools/*::
Container shared data.
*/usr/share/doc/compute-tools*::
Container documentation files.
-*/var/cache/open-infrastructure/container*::
+*/var/cache/container*::
Container cache directory.
*/var/lib/machines*::
Container root directory.
-*/var/log/open-infrastructure*::
+*/var/log/compute-tools*::
Container log files.
diff --git a/share/scripts/curl b/share/scripts/curl
index 465ecbe..98c2b82 100755
--- a/share/scripts/curl
+++ b/share/scripts/curl
@@ -15,19 +15,21 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
PROJECT="open-infrastructure"
SOFTWARE="compute-tools"
PROGRAM="container"
-SCRIPT="${0}"
-HOOKS="/etc/${PROJECT}/${PROGRAM}/hooks"
-KEYS="/etc/${PROJECT}/${PROGRAM}/keys"
+HOOKS="/etc/${SOFTWARE}/hooks"
+KEYS="/etc/${SOFTWARE}/keys"
MACHINES="/var/lib/machines"
-CACHE="/var/cache/${PROJECT}/${PROGRAM}/system"
+CACHE="/var/cache/${PROGRAM}/system"
+
+SCRIPT="${0}"
+export SCRIPT
Parameters ()
{
@@ -267,7 +269,7 @@ then
Debconf
# Run debconf parts
- for DEBCONF_SCRIPT in /usr/share/${PROJECT}/${PROGRAM}/scripts/curl.d/*
+ for DEBCONF_SCRIPT in /usr/share/${SOFTWARE}/scripts/curl.d/*
do
if [ -x "${DEBCONF_SCRIPT}" ]
then
diff --git a/share/scripts/curl.d/0001-debconf b/share/scripts/curl.d/0001-debconf
index 0910480..083d469 100755
--- a/share/scripts/curl.d/0001-debconf
+++ b/share/scripts/curl.d/0001-debconf
@@ -15,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
diff --git a/share/scripts/debconf b/share/scripts/debconf
index 7f2bf3d..1994926 100755
--- a/share/scripts/debconf
+++ b/share/scripts/debconf
@@ -15,20 +15,21 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
PROJECT="open-infrastructure"
SOFTWARE="compute-tools"
PROGRAM="container"
-SCRIPT="${0}"
-export SCRIPT
-CONFIG="/etc/${PROJECT}/${PROGRAM}/config"
-HOOKS="/etc/${PROJECT}/${PROGRAM}/hooks"
+CONFIG="/etc/${SOFTWARE}/config"
+HOOKS="/etc/${SOFTWARE}/hooks"
MACHINES="/var/lib/machines"
+SCRIPT="${0}"
+export SCRIPT
+
Parameters ()
{
GETOPT_LONGOPTIONS="bind:,bind-ro:,script:,name:,preseed-file:"
@@ -448,37 +449,6 @@ EOF
rm -f "${DIRECTORY}/etc/mtab"
ln -s /proc/self/mounts "${DIRECTORY}/etc/mtab"
- # Temporary hack for dpkg
- if [ -e "${DIRECTORY}/etc/dpkg/origins/default" ]
- then
- rm -f "${DIRECTORY}/etc/dpkg/origins/default"
- Chroot "${DIRECTORY}" "dpkg-reconfigure base-files"
- fi
-
- # Temporary hack for base-files
- for FILE in motd.tail motd profile
- do
- if [ -e "${DIRECTORY}/usr/share/base-files/${FILE}" ]
- then
- rm -f "${DIRECTORY}/etc/${FILE}"
- cp "${DIRECTORY}/usr/share/base-files/${FILE}" "${DIRECTORY}/etc"
- fi
- done
-
- # Temporary hack for readline
- if [ -e "${DIRECTORY}/etc/inputrc" ]
- then
- rm -f "${DIRECTORY}/etc/inputrc"
- cp "${DIRECTORY}/usr/share/readline/inputrc" "${DIRECTORY}/etc"
- fi
-
- # Temporary hack for sysvinit
- if [ -e "${DIRECTORY}/etc/inittab" ]
- then
- rm -f "${DIRECTORY}/etc/inittab"
- cp "${DIRECTORY}/usr/share/sysvinit/inittab" "${DIRECTORY}/etc/inittab"
- fi
-
# Removing resolv.conf
rm -f "${DIRECTORY}/etc/resolv.conf"
cp /etc/resolv.conf "${DIRECTORY}/etc"
@@ -521,7 +491,7 @@ EOF
echo "deb ${PARENT_MIRROR_SECURITY} ${PARENT_DIST}/updates ${PARENT_AREA}" >> "${DIRECTORY}/etc/apt/sources.list.d/debian.list"
;;
- bullseye-security)
+ ${PARENT_DIST}-security)
echo "deb ${PARENT_MIRROR_SECURITY} ${PARENT_DIST}-security ${PARENT_AREA}" >> "${DIRECTORY}/etc/apt/sources.list.d/debian.list"
;;
@@ -674,16 +644,6 @@ EOF
done
fi
- # Temporary hack for base-files (base-files gets upgraded, so run it second time)
- for FILE in motd.tail motd profile
- do
- if [ -e "${DIRECTORY}/usr/share/base-files/${FILE}" ]
- then
- rm -f "${DIRECTORY}/etc/${FILE}"
- cp "${DIRECTORY}/usr/share/base-files/${FILE}" "${DIRECTORY}/etc"
- fi
- done
-
if [ -n "${PACKAGES}" ]
then
Chroot "${DIRECTORY}" "apt --option Dpkg::Options::=--force-confnew --yes install ${PACKAGES}"
@@ -1121,7 +1081,7 @@ do
done
# Run debconf parts
-for DEBCONF_SCRIPT in "/usr/share/${PROJECT}/${PROGRAM}/scripts/debconf.d"/*
+for DEBCONF_SCRIPT in "/usr/share/${SOFTWARE}/scripts/debconf.d"/*
do
if [ -x "${DEBCONF_SCRIPT}" ]
then
@@ -1132,7 +1092,7 @@ done
# Read-in configuration from debconf
. "${DEBCONF_TMPDIR}/debconf.default"
-CACHE="/var/cache/${PROJECT}/${PROGRAM}/${MODE}"
+CACHE="/var/cache/${PROGRAM}/${MODE}"
SYSTEM="${MACHINES}/${NAME}"
## Generic parts
@@ -1145,7 +1105,7 @@ then
mv "${CACHE}/${DISTRIBUTION}_${ARCHITECTURE}.tmp" "${CACHE}/${DISTRIBUTION}_${ARCHITECTURE}"
fi
-Upgrade_system "${CACHE}/${DISTRIBUTION}_${ARCHITECTURE}" || echo "W: If upgrading the system failed, try removing the cache for your distribution in /var/cache/${PROJECT}/${PROGRAM}"
+Upgrade_system "${CACHE}/${DISTRIBUTION}_${ARCHITECTURE}" || echo "W: If upgrading the system failed, try removing the cache for your distribution in /var/cache/${PROGRAM}"
Cleanup_system "${CACHE}/${DISTRIBUTION}_${ARCHITECTURE}"
## Specific parts
diff --git a/share/scripts/debconf.d/0001-preseed-file b/share/scripts/debconf.d/0001-preseed-file
index 4fec6b0..d70e4e1 100755
--- a/share/scripts/debconf.d/0001-preseed-file
+++ b/share/scripts/debconf.d/0001-preseed-file
@@ -15,14 +15,15 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
PROJECT="open-infrastructure"
+SOFTWARE="compute-tools"
PROGRAM="container"
-CONFIG="/etc/${PROJECT}/${PROGRAM}/debconf"
+CONFIG="/etc/${SOFTWARE}/debconf"
DEBCONF_NOWARNINGS="true"
export DEBCONF_NOWARNINGS
@@ -43,7 +44,7 @@ then
elif [ "$(ls ${CONFIG}/*/${NAME}.cfg 2>/dev/null | wc -l)" -eq 1 ]
then
# user did not specify a pressed file, but there is 1 (and only 1)
- # matching in a sub-directory of /etc/${PROJECT}/${PROGRAM}/debconf
+ # matching in a sub-directory of /etc/${SOFTWARE}/debconf
FILE="$(ls ${CONFIG}/*/${NAME}.cfg)"
diff --git a/share/scripts/debconf.d/0002-preseed-debconf b/share/scripts/debconf.d/0002-preseed-debconf
index 9bc9fcf..4bc4da6 100755
--- a/share/scripts/debconf.d/0002-preseed-debconf
+++ b/share/scripts/debconf.d/0002-preseed-debconf
@@ -15,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
diff --git a/share/scripts/debconf.d/0003-debconf b/share/scripts/debconf.d/0003-debconf
index dda3821..c1c4e79 100755
--- a/share/scripts/debconf.d/0003-debconf
+++ b/share/scripts/debconf.d/0003-debconf
@@ -15,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
@@ -53,15 +53,15 @@ Distribution ()
then
case "${MODE}" in
debian)
- db_subst container/distribution CHOICES "Debian GNU/Linux 9 \"stretch\", Debian GNU/Linux 10 \"buster\", Debian GNU/Linux 11 \"bullseye\", Debian GNU/Linux unstable/sid"
- db_subst container/distribution CHOICES_C "stretch, buster, bullseye, sid"
+ db_subst container/distribution CHOICES "Debian GNU/Linux 10 \"buster\", Debian GNU/Linux 11 \"bullseye\", Debian GNU/Linux testing/bookworm, Debian GNU/Linux unstable/sid"
+ db_subst container/distribution CHOICES_C "buster, bullseye, bookworm, sid"
db_set container/distribution bullseye
db_fset container/distribution seen false
;;
progress-linux)
- db_subst container/distribution CHOICES "Progress Linux 5 (engywuck), Progress Linux 5+ (engywuck-backports), Progress Linux 6 (fuchur), Progress Linux 6+ (fuchur-backports)"
+ db_subst container/distribution CHOICES "Progress Linux 5 (engywuck), Progress Linux 5.99 (engywuck-backports), Progress Linux 6 (fuchur), Progress Linux 6.99 (fuchur-backports)"
db_subst container/distribution CHOICES_C "engywuck, engywuck-backports, fuchur, fuchur-backports"
db_set container/distribution fuchur-backports
@@ -352,7 +352,7 @@ Mirror_security ()
then
case "${MODE}" in
debian)
- db_set container/mirror-security http://security.debian.org
+ db_set container/mirror-security https://security.debian.org
db_fset container/mirror-security seen false
;;
@@ -373,7 +373,7 @@ Mirror_security ()
then
case "${MODE}" in
debian)
- MIRROR_SECURITY="http://security.debian.org"
+ MIRROR_SECURITY="https://security.debian.org"
;;
*)
@@ -445,7 +445,7 @@ Parent_mirror_security ()
then
case "${MODE}" in
progress-linux)
- db_set container/parent-mirror-security http://security.debian.org
+ db_set container/parent-mirror-security https://security.debian.org
db_fset container/parent-mirror-security seen false
db_settitle container/title
@@ -466,7 +466,7 @@ Parent_mirror_security ()
then
case "${MODE}" in
progress-linux)
- PARENT_MIRROR_SECURITY="http://security.debian.org"
+ PARENT_MIRROR_SECURITY="https://security.debian.org"
;;
*)
diff --git a/share/scripts/debootstrap b/share/scripts/debootstrap
index 98f202b..f0db7e8 100755
--- a/share/scripts/debootstrap
+++ b/share/scripts/debootstrap
@@ -15,7 +15,7 @@
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
set -e
@@ -25,7 +25,7 @@ PROGRAM="container"
SCRIPT="$(basename ${0})"
-HOOKS="/etc/${PROJECT}/${PROGRAM}/hooks"
+HOOKS="/etc/${SOFTWARE}/hooks"
MACHINES="/var/lib/machines"
Parameters ()