summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2016-07-03 13:32:56 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2016-07-03 13:33:15 +0000
commitaba24e71d2530941aae2e2151a72447f126990d1 (patch)
tree3306d2de2f70b5b8ca40c8f0c8ed14003df0ab8c
parentAdding debian version 20160601-1. (diff)
downloadopen-infrastructure-service-tools-aba24e71d2530941aae2e2151a72447f126990d1.tar.xz
open-infrastructure-service-tools-aba24e71d2530941aae2e2151a72447f126990d1.zip
Merging upstream version 20160701.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--CHANGELOG.txt7
-rw-r--r--Makefile42
-rw-r--r--README.txt62
-rw-r--r--VERSION2
-rw-r--r--share/apache/mods/000-apache-icons.conf2
-rw-r--r--share/man/Makefile43
-rw-r--r--share/man/apache-icons.7.txt118
7 files changed, 260 insertions, 16 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index b79088c..74588f7 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,10 @@
+2016-07-01 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20160701.
+ * Added further file suffixes for text icon.
+ * Correcting and updating existing documentation.
+ * Adding apache-icons manpage.
+
2016-06-01 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20160601.
diff --git a/Makefile b/Makefile
index 2b74b53..537f053 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Makefile
-# apache-icons - Tango Icon Theme for Apache Webserver
+# apache-icons - Alternative icons for Apache autoindex
# Copyright (C) 2014-2016 Daniel Baumann <daniel.baumann@open-infrastructure.net>
#
# This program is free software: you can redistribute it and/or modify
@@ -18,9 +18,13 @@
SHELL := sh -e
+SOFTWARE = apache-icons
+
all: build
-build:
+build: share/man/*.txt
+ $(MAKE) -C share/man
+
for ICON in share/icons/*; \
do \
ICON="$$(basename $${ICON})"; \
@@ -41,15 +45,15 @@ build:
done
install: build
- mkdir -p $(DESTDIR)/usr/share/apache-icons
- cp -a build/* $(DESTDIR)/usr/share/apache-icons
+ mkdir -p $(DESTDIR)/usr/share/$(SOFTWARE)
+ cp -a build/* $(DESTDIR)/usr/share/$(SOFTWARE)
- for DIRECTORY in $(DESTDIR)/usr/share/apache-icons/*-png; \
+ for DIRECTORY in $(DESTDIR)/usr/share/$(SOFTWARE)/*-png; \
do \
cp -a share/common/*.png $${DIRECTORY}; \
done
- for DIRECTORY in $(DESTDIR)/usr/share/apache-icons/*-svg; \
+ for DIRECTORY in $(DESTDIR)/usr/share/$(SOFTWARE)/*-svg; \
do \
cp -a share/common/*.svg $${DIRECTORY}; \
done
@@ -60,10 +64,34 @@ install: build
mkdir -p $(DESTDIR)/etc/apache2/mods-available
cp -a share/apache/mods/* $(DESTDIR)/etc/apache2/mods-available
+ for SECTION in $$(seq 1 8); \
+ do \
+ if ls share/man/*.$${SECTION} > /dev/null 2>&1; \
+ then \
+ mkdir -p $(DESTDIR)/usr/share/man/man$${SECTION}; \
+ cp share/man/*.$${SECTION} $(DESTDIR)/usr/share/man/man$${SECTION}; \
+ fi; \
+ done
+
uninstall:
- rm -rf $(DESTDIR)/usr/share/apache-icons
+ for SECTION in $$(seq 1 8); \
+ do \
+ for FILE in share/man/*.$${SECTION}; \
+ do \
+ if [ -e "$${FILE}" ]; \
+ then \
+ rm -f $(DESTDIR)/usr/share/man/man$${SECTION}/$$(basename $${FILE}); \
+ fi; \
+ done; \
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/usr/share/man/man$${SECTION} || true; \
+ done
+
+ rm -rf $(DESTDIR)/usr/share/$(SOFTWARE)/*
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/usr/share/$(SOFTWARE) || true
clean:
+ $(MAKE) -C share/man clean
+
rm -rf build
distclean: clean
diff --git a/README.txt b/README.txt
index 664946f..4e979c0 100644
--- a/README.txt
+++ b/README.txt
@@ -1,4 +1,4 @@
-apache-icons - alternative icons for Apache autoindex
+apache-icons - Alternative icons for Apache autoindex
=====================================================
@@ -15,7 +15,10 @@ apache-icons provides alternative icons for Apache autoindex.
2. Download
-----------
- * https://github.com/open-infrastructure/apache-icons
+ * Upstream Releases: https://files.open-infrastructure.net/software/apache-icons/upstream
+ * Upstream Sources: https://sources.open-infrastructure.net/software/apache-icons
+ * Debian Releases: https://files.open-infrastructure.net/software/apache-icons/debian
+ * Debian Sources: https://sources.progress-linux.org/users/daniel/debian/packages/open-infrastructure-apache-icons
3. Installation
@@ -24,24 +27,69 @@ apache-icons provides alternative icons for Apache autoindex.
3.1 Source
----------
- 1. sudo apt install imagemagick librsvg2-bin
- 2. git clone https://github.com/open-infrastructure/apache-icons
+ 1. sudo apt install asciidoc git docbook-xml docbook-xsl libxml2-utils make xsltproc imagemagick librsvg2-bin
+ 2. git clone https://sources.open-infrastructure.net/software/apache-icons
3. cd apache-icons && sudo make install
+3.2 Debian 9 (stretch) and newer
+--------------------------------
+
+ * sudo apt install apache-icons
+
4. Development
--------------
-Bug reports, feature requests, and patches are welcome via Github:
+Bug reports, feature requests, and patches are welcome via Debian Bug Tracking System:
- * https://github.com/open-infrastructure/apache-icons
+ * https://bugs.debian.org
Please base them against the 'next' Git branch using common sense:
* https://www.kernel.org/doc/Documentation/SubmittingPatches
-5. Authors
+5. Known Limitations
+--------------------
+
+Changing from one icon set to the other requires a reload of the apache webserver.
+
+
+6. Usage
+--------
+
+The default icon theme is determined by the /usr/share/apache-icons/default
+(and /usr/share/apache-icons/default.conf respectivly) file.
+
+On Debian based system "sudo update-alternatives --config apache-icons" can be
+used to automatically select the active icon theme (including the default apache
+icons).
+
+The following themes are available:
+
+ * awesome-png: Font Awesome based, PNG format
+ * awesome-svg: Font Awesome based, SVG format
+ * tango-png: Tango Icons based, PNG format
+ * tango-svg: Tango Icons based, SVG format
+
+The SVG themes are preferable because they are sharper and scale losless.
+They require somewhat modern browsers though.
+
+An example of the tango-svg theme can be seen on
+https://files.open-infrastructure.net.
+
+
+7. Links
+--------
+
+ * Font Awesome:
+ http://fontawesome.io/
+
+ * Tango Desktop Project:
+ http://tango.freedesktop.org/
+
+
+8. Authors
----------
* Daniel Baumann <daniel.baumann@open-infrastructure.net>
diff --git a/VERSION b/VERSION
index 64fa36a..f48d32f 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-20160601
+20160701
diff --git a/share/apache/mods/000-apache-icons.conf b/share/apache/mods/000-apache-icons.conf
index d5932c5..bd9c2b5 100644
--- a/share/apache/mods/000-apache-icons.conf
+++ b/share/apache/mods/000-apache-icons.conf
@@ -35,7 +35,7 @@
AddIcon /icons/spreadsheet.${FORMAT} .ods .ots .xls .xlt .xlsx .xltx
- AddIcon /icons/text.${FORMAT} .txt .htm .html .shtml .xhtml .asc .changes .dsc
+ AddIcon /icons/text.${FORMAT} .txt .htm .html .shtml .xhtml .asc .gpg .sign .changes .dsc MD5SUMS SHA1SUMS SHA224SUMS SHA256SUMS SHA384SUMS SHA512SUMS
AddIconByType (TXT,/icons/text.${FORMAT}) text/*
AddIcon (VID,/icons/video.${FORMAT}) .mkv .mp4 .ogm
diff --git a/share/man/Makefile b/share/man/Makefile
new file mode 100644
index 0000000..43f6286
--- /dev/null
+++ b/share/man/Makefile
@@ -0,0 +1,43 @@
+# Makefile
+
+# apache-icons - Alternative icons for Apache autoindex
+# Copyright (C) 2014-2016 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# Depends: asciidoc dblatex docbook-xsl libxml2-utils source-highlight
+
+A2X = a2x \
+ --asciidoc-opts "-a revdate=$(shell cat ../../VERSION.txt)" \
+ --doctype=manpage
+
+SHELL := sh -e
+
+all: build
+
+clean:
+ rm -f *.[0-9]
+ rm -f *.xml
+
+build: man
+
+rebuild: clean build
+
+man: *.txt
+ for FILE in *.txt; \
+ do \
+ $(A2X) --format=manpage $${FILE}; \
+ done
+
+.PHONY: all clean build rebuild man
diff --git a/share/man/apache-icons.7.txt b/share/man/apache-icons.7.txt
new file mode 100644
index 0000000..48d7abc
--- /dev/null
+++ b/share/man/apache-icons.7.txt
@@ -0,0 +1,118 @@
+// apache-icons - Alternative icons for Apache autoindex
+// Copyright (C) 2014-2016 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+//
+// This program is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+APACHE-ICONS(7)
+===============
+:doctype: manpage
+:man manual: Open Infrastructure
+:man source: container-tools
+:man version: {revnumber}
+
+
+NAME
+----
+apache-icons - Alternative icons for Apache autoindex
+
+
+DESCRIPTION
+-----------
+"The Apache HTTP Server is the world's most used web server software."
+ -- Wikipedia (https://en.wikipedia.org/wiki/Apache_HTTP_Server)
+
+apache-icons provides alternative icons for Apache autoindex.
+
+
+DOWNLOAD
+--------
+
+ * Upstream Releases: https://files.open-infrastructure.net/software/apache-icons/upstream
+ * Upstream Sources: https://sources.open-infrastructure.net/software/apache-icons
+ * Debian Releases: https://files.open-infrastructure.net/software/apache-icons/debian
+ * Debian Sources: https://sources.progress-linux.org/users/daniel/debian/packages/open-infrastructure-apache-icons
+
+
+INSTALLATION
+------------
+
+SOURCE
+~~~~~~
+
+ 1. sudo apt install asciidoc git docbook-xml docbook-xsl libxml2-utils make xsltproc imagemagick librsvg2-bin
+ 2. git clone https://sources.open-infrastructure.net/software/apache-icons
+ 3. cd apache-icons && sudo make install
+
+DEBIAN 9 (STRETCH) AND NEWER
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+ * sudo apt install apache-icons
+
+
+DEVELOPMENT
+-----------
+
+Bug reports, feature requests, and patches are welcome via Debian Bug Tracking System:
+
+ * https://bugs.debian.org
+
+Please base them against the 'next' Git branch using common sense:
+
+ * https://www.kernel.org/doc/Documentation/SubmittingPatches
+
+
+KNOWN LIMITATIONS
+-----------------
+
+Changing from one icon set to the other requires a reload of the apache webserver.
+
+
+USAGE
+-----
+
+The default icon theme is determined by the /usr/share/apache-icons/default
+(and /usr/share/apache-icons/default.conf respectivly) file.
+
+On Debian based system "sudo update-alternatives --config apache-icons" can be
+used to automatically select the active icon theme (including the default apache
+icons).
+
+The following themes are available:
+
+ * awesome-png: Font Awesome based, PNG format
+ * awesome-svg: Font Awesome based, SVG format
+ * tango-png: Tango Icons based, PNG format
+ * tango-svg: Tango Icons based, SVG format
+
+The SVG themes are preferable because they are sharper and scale losless.
+They require somewhat modern browsers though.
+
+An example of the tango-svg theme can be seen on
+https://files.open-infrastructure.net.
+
+
+LINKS
+-----
+
+*Font Awesome:*::
+ http://fontawesome.io/
+
+*Tango Desktop Project:*::
+ http://tango.freedesktop.org/
+
+
+AUTHORS
+-------
+
+ * Daniel Baumann <daniel.baumann@open-infrastructure.net>