summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-06-16 21:58:47 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-06-16 21:58:47 +0000
commiteddbee038320e5db1049535e71c8954db5076143 (patch)
tree4e860eb0e359878b13c521187c4101179110d257
parentReleasing debian version 20220614-1. (diff)
downloadopen-infrastructure-service-tools-eddbee038320e5db1049535e71c8954db5076143.tar.xz
open-infrastructure-service-tools-eddbee038320e5db1049535e71c8954db5076143.zip
Merging upstream version 20220615.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGELOG.txt8
-rw-r--r--Makefile3
-rw-r--r--VERSION.txt2
-rwxr-xr-xdnsdist/bin/dnsdist-console3
4 files changed, 14 insertions, 2 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index db062f2..42986e9 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,11 @@
+2022-06-15 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20220615.
+
+ [ Daniel Baumann ]
+ * Correcting breaking extra-quotes in dnsdist-console.
+ * Adding git commands to release target in top-level Makefile.
+
2022-06-14 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20220614.
diff --git a/Makefile b/Makefile
index 3c55809..a9a2be1 100644
--- a/Makefile
+++ b/Makefile
@@ -77,6 +77,9 @@ distclean:
reinstall: uninstall install
release: distclean
+ git commit -a -s -S -m 'Releasing version $(VERSION).' || true
+ git tag -s -m 'Tagging version $(VERSION).' v$(VERSION) || true
+
mkdir service-tools-$(VERSION)
find . -mindepth 1 -maxdepth 1 -and -not -name ".git*" -and -not -name debian -and -not -name service-tools-$(VERSION) -exec cp \-a {} service-tools-$(VERSION) \;
diff --git a/VERSION.txt b/VERSION.txt
index f6e8eb7..fa673f3 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20220614
+20220615
diff --git a/dnsdist/bin/dnsdist-console b/dnsdist/bin/dnsdist-console
index 8fcd3b0..ea26d63 100755
--- a/dnsdist/bin/dnsdist-console
+++ b/dnsdist/bin/dnsdist-console
@@ -57,4 +57,5 @@ then
Usage
fi
-dnsdist "${OPTIONS}"
+# shellcheck disable=SC2086
+dnsdist ${OPTIONS}