summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 15 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 1ad63c1..b0d7d5c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,6 @@
#!/usr/bin/make -f
-PACKAGE := apache-tools
+PACKAGES := apache
%:
dh ${@} --with apache2
@@ -8,10 +8,19 @@ PACKAGE := apache-tools
override_dh_auto_build:
# disabled
-override_dh_auto_install:
- dh_auto_install -- DESTDIR=$(CURDIR)/debian/open-infrastructure-$(PACKAGE)
+override_dh_auto_clean:
+ for PACKAGE in $(PACKAGES); \
+ do \
+ $(MAKE) -C $${PACKAGE} clean; \
+ done
- rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/CHANGELOG.txt
- rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/LICENSE.txt
+override_dh_auto_install:
+ for PACKAGE in $(PACKAGES); \
+ do \
+ $(MAKE) -C $${PACKAGE} DESTDIR=$(CURDIR)/debian/open-infrastructure-$${PACKAGE}-tools install; \
+ done
- mv debian/open-infrastructure-$(PACKAGE)/usr/share/doc/* debian/open-infrastructure-$(PACKAGE)/usr/share/doc/open-infrastructure-$(PACKAGE)
+ # apache-tools
+ rm -f debian/open-infrastructure-apache-tools/usr/share/doc/apache-tools/CHANGELOG.txt
+ rm -f debian/open-infrastructure-apache-tools/usr/share/doc/apache-tools/LICENSE.txt
+ mv debian/open-infrastructure-apache-tools/usr/share/doc/* debian/open-infrastructure-apache-tools/usr/share/doc/open-infrastructure-apache-tools