summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2017-04-08 10:27:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2017-04-08 11:17:27 +0000
commitbd76ad8258e38547192065e3e0127f656f3555bf (patch)
tree86872637bddb348d6228d172125b257bb2d4d737 /debian/rules
parentAdding upstream version 20170405. (diff)
downloadopen-infrastructure-storage-tools-bd76ad8258e38547192065e3e0127f656f3555bf.tar.xz
open-infrastructure-storage-tools-bd76ad8258e38547192065e3e0127f656f3555bf.zip
Adding debian version 20170405-1.debian/20170405-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0b0fa18
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+PACKAGE := storage-tools
+
+%:
+ dh ${@} --parallel --with apache2,systemd
+
+override_dh_auto_build:
+ # disabled
+
+override_dh_auto_install:
+ dh_auto_install
+
+ rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/CHANGELOG.txt
+ rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/LICENSE.txt
+
+ mv debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE) debian/open-infrastructure-$(PACKAGE)/usr/share/doc/open-infrastructure-$(PACKAGE)