summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 14:59:24 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 14:59:24 +0000
commitf684d748fd905cee03438d433ccc56f759ce26a4 (patch)
tree62e519f2e95deb4df3917f4144f1310744d0331b
parentAdding debian version 1.6~rc1-1. (diff)
downloadpdlzip-f684d748fd905cee03438d433ccc56f759ce26a4.tar.xz
pdlzip-f684d748fd905cee03438d433ccc56f759ce26a4.zip
Merging upstream version 1.6.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--ChangeLog6
-rw-r--r--INSTALL2
-rw-r--r--Makefile.in6
-rwxr-xr-xconfigure2
-rw-r--r--doc/pdlzip.16
-rw-r--r--lzip.h4
-rw-r--r--main.c6
7 files changed, 18 insertions, 14 deletions
diff --git a/ChangeLog b/ChangeLog
index a814cfe..d4fcfeb 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,6 @@
-2015-04-09 Antonio Diaz Diaz <antonio@gnu.org>
+2015-05-26 Antonio Diaz Diaz <antonio@gnu.org>
- * Version 1.6-rc1 released.
+ * Version 1.6 released.
* main.c (close_and_set_permissions): Behave like 'cp -p'.
* Makefile.in: Added new targets 'install*-compress'.
@@ -19,7 +19,7 @@
* main.c: Added new option '-o, --output'.
* main.c: Accept more than one file in command line.
* Decompression time has been reduced by 5%.
- * main.c: '--test' no more needs '/dev/null'.
+ * main.c: '--test' no longer needs '/dev/null'.
* Fixed return value of '-d' and '-t' in case of data error.
* main.c: Changed info shown at verbosity levels 2 and 3.
* Ignore option '-n, --threads' for compatibility with plzip.
diff --git a/INSTALL b/INSTALL
index 22757a0..489393d 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,7 +1,7 @@
Requirements
------------
You will need a C compiler.
-I use gcc 4.9.1 and 3.3.6, but the code should compile with any
+I use gcc 4.9.1 and 4.1.2, but the code should compile with any
standards compliant compiler.
Gcc is available at http://gcc.gnu.org.
diff --git a/Makefile.in b/Makefile.in
index f85a000..1b4ab5b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -18,13 +18,13 @@ objs = carg_parser.o LzFind.o LzmaEnc.o LzmaDec.o main.o
all : $(progname)
$(progname) : $(objs)
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(objs)
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(objs)
main.o : main.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -DPROGVERSION=\"$(pkgversion)\" -c -o $@ $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -DPROGVERSION=\"$(pkgversion)\" -c -o $@ $<
%.o : %.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
$(objs) : Makefile
carg_parser.o : carg_parser.h
diff --git a/configure b/configure
index 6e79698..40db552 100755
--- a/configure
+++ b/configure
@@ -6,7 +6,7 @@
# to copy, distribute and modify it.
pkgname=pdlzip
-pkgversion=1.6-rc1
+pkgversion=1.6
progname=pdlzip
srctrigger=doc/${progname}.1
diff --git a/doc/pdlzip.1 b/doc/pdlzip.1
index 67c3bb0..0c97f2c 100644
--- a/doc/pdlzip.1
+++ b/doc/pdlzip.1
@@ -1,5 +1,5 @@
.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.46.1.
-.TH PDLZIP "1" "April 2015" "pdlzip 1.6-rc1" "User Commands"
+.TH PDLZIP "1" "May 2015" "pdlzip 1.6" "User Commands"
.SH NAME
pdlzip \- reduces the size of files
.SH SYNOPSIS
@@ -8,6 +8,8 @@ pdlzip \- reduces the size of files
.SH DESCRIPTION
Pdlzip \- A "public domain" version of the lzip data compressor
also able to decompress legacy lzma\-alone (.lzma) files.
+Lzma\-alone is a very bad format. If you keep any lzma\-alone files, it is
+advisable to recompress them to lzip format.
.SH OPTIONS
.TP
\fB\-h\fR, \fB\-\-help\fR
@@ -26,7 +28,7 @@ decompress
overwrite existing output files
.TP
\fB\-F\fR, \fB\-\-recompress\fR
-force recompression of compressed files
+force re\-compression of compressed files
.TP
\fB\-k\fR, \fB\-\-keep\fR
keep (don't delete) input files
diff --git a/lzip.h b/lzip.h
index f99edba..3b8d172 100644
--- a/lzip.h
+++ b/lzip.h
@@ -164,10 +164,10 @@ static inline bool Fh_set_dictionary_size( File_header data, const unsigned sz )
if( sz > min_dictionary_size )
{
const unsigned base_size = 1 << data[5];
- const unsigned wedge = base_size / 16;
+ const unsigned fraction = base_size / 16;
int i;
for( i = 7; i >= 1; --i )
- if( base_size - ( i * wedge ) >= sz )
+ if( base_size - ( i * fraction ) >= sz )
{ data[5] |= ( i << 5 ); break; }
}
return true;
diff --git a/main.c b/main.c
index c5f8cff..7972e7d 100644
--- a/main.c
+++ b/main.c
@@ -98,6 +98,8 @@ static void show_help( void )
{
printf( "%s - A \"public domain\" version of the lzip data compressor\n", Program_name );
printf( "also able to decompress legacy lzma-alone (.lzma) files.\n"
+ "Lzma-alone is a very bad format. If you keep any lzma-alone files, it is\n"
+ "advisable to recompress them to lzip format.\n"
"\nUsage: %s [options] [files]\n", invocation_name );
printf( "\nOptions:\n"
" -h, --help display this help and exit\n"
@@ -105,7 +107,7 @@ static void show_help( void )
" -c, --stdout send output to standard output\n"
" -d, --decompress decompress\n"
" -f, --force overwrite existing output files\n"
- " -F, --recompress force recompression of compressed files\n"
+ " -F, --recompress force re-compression of compressed files\n"
" -k, --keep keep (don't delete) input files\n"
" -m, --match-length=<bytes> set match length limit in bytes [36]\n"
" -o, --output=<file> if reading stdin, place the output into <file>\n"
@@ -221,7 +223,7 @@ static unsigned long getnum( const char * const ptr,
static int get_dict_size( const char * const arg )
{
char * tail;
- int bits = strtol( arg, &tail, 0 );
+ const int bits = strtol( arg, &tail, 0 );
if( bits >= min_dictionary_bits &&
bits <= max_dictionary_bits && *tail == 0 )
return ( 1 << bits );