summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 14:57:58 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 14:57:58 +0000
commitd7736b5d0bf2a84c733be54425e9bbe1bc69fe24 (patch)
tree8173a652f699089b4525502d4388c722a7c0f86b
parentAdding upstream version 1.5~rc1. (diff)
downloadpdlzip-d7736b5d0bf2a84c733be54425e9bbe1bc69fe24.tar.xz
pdlzip-d7736b5d0bf2a84c733be54425e9bbe1bc69fe24.zip
Adding upstream version 1.5.upstream/1.5
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--ChangeLog4
-rw-r--r--Makefile.in3
-rw-r--r--carg_parser.c4
-rwxr-xr-xconfigure2
-rw-r--r--doc/pdlzip.17
-rw-r--r--main.c9
6 files changed, 15 insertions, 14 deletions
diff --git a/ChangeLog b/ChangeLog
index e8b6ef1..7df02ff 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,6 @@
-2013-07-26 Antonio Diaz Diaz <antonio@gnu.org>
+2013-09-14 Antonio Diaz Diaz <antonio@gnu.org>
- * Version 1.5-rc1 released.
+ * Version 1.5 released.
* main.c (show_header): Do not show header version in lzip mode.
* Minor fixes.
diff --git a/Makefile.in b/Makefile.in
index bea7569..4a36df7 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -45,8 +45,7 @@ $(VPATH)/doc/$(pkgname).info : $(VPATH)/doc/$(pkgname).texinfo
man : $(VPATH)/doc/$(progname).1
$(VPATH)/doc/$(progname).1 : $(progname)
- help2man -n 'reduces the size of files' \
- -o $@ --no-info ./$(progname)
+ help2man -n 'reduces the size of files' -o $@ --no-info ./$(progname)
Makefile : $(VPATH)/configure $(VPATH)/Makefile.in
./config.status
diff --git a/carg_parser.c b/carg_parser.c
index 2958c67..b266751 100644
--- a/carg_parser.c
+++ b/carg_parser.c
@@ -205,12 +205,12 @@ char ap_init( struct Arg_parser * const ap,
while( argind < argc )
{
const unsigned char ch1 = argv[argind][0];
- const unsigned char ch2 = ( ch1 ? argv[argind][1] : 0 );
+ const unsigned char ch2 = ch1 ? argv[argind][1] : 0;
if( ch1 == '-' && ch2 ) /* we found an option */
{
const char * const opt = argv[argind];
- const char * const arg = (argind + 1 < argc) ? argv[argind+1] : 0;
+ const char * const arg = ( argind + 1 < argc ) ? argv[argind+1] : 0;
if( ch2 == '-' )
{
if( !argv[argind][2] ) { ++argind; break; } /* we found "--" */
diff --git a/configure b/configure
index 458caa2..07e2131 100755
--- a/configure
+++ b/configure
@@ -6,7 +6,7 @@
# to copy, distribute and modify it.
pkgname=pdlzip
-pkgversion=1.5-rc1
+pkgversion=1.5
progname=pdlzip
srctrigger=doc/${progname}.1
diff --git a/doc/pdlzip.1 b/doc/pdlzip.1
index 1029375..c6ff809 100644
--- a/doc/pdlzip.1
+++ b/doc/pdlzip.1
@@ -1,5 +1,5 @@
.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.37.1.
-.TH PDLZIP "1" "July 2013" "Pdlzip 1.5-rc1" "User Commands"
+.TH PDLZIP "1" "September 2013" "Pdlzip 1.5" "User Commands"
.SH NAME
Pdlzip \- reduces the size of files
.SH SYNOPSIS
@@ -41,7 +41,7 @@ if reading stdin, place the output into <file>
suppress all messages
.TP
\fB\-s\fR, \fB\-\-dictionary\-size=\fR<bytes>
-set dictionary size limit in bytes [8MiB]
+set dictionary size limit in bytes [8 MiB]
.TP
\fB\-t\fR, \fB\-\-test\fR
test compressed file integrity
@@ -65,7 +65,8 @@ Ki = KiB = 2^10 = 1024, M = 10^6, Mi = 2^20, G = 10^9, Gi = 2^30, etc...
The bidimensional parameter space of LZMA can't be mapped to a linear
scale optimal for all files. If your files are large, very repetitive,
etc, you may need to use the \fB\-\-match\-length\fR and \fB\-\-dictionary\-size\fR
-options directly to achieve optimal performance.
+options directly to achieve optimal performance. For example, \fB\-9m64\fR
+usually compresses executables more (and faster) than \fB\-9\fR.
.PP
Exit status: 0 for a normal exit, 1 for environmental problems (file
not found, invalid flags, I/O errors, etc), 2 to indicate a corrupt or
diff --git a/main.c b/main.c
index 0428c84..037aa5e 100644
--- a/main.c
+++ b/main.c
@@ -73,8 +73,8 @@ struct { const char * from; const char * to; } const known_extensions[] = {
struct Lzma_options
{
- int dictionary_size; /* 4KiB..512MiB */
- int match_len_limit; /* 5..273 */
+ int dictionary_size; /* 4 KiB .. 512 MiB */
+ int match_len_limit; /* 5 .. 273 */
};
enum Mode { m_compress, m_decompress, m_test };
@@ -104,7 +104,7 @@ static void show_help( void )
" -m, --match-length=<bytes> set match length limit in bytes [36]\n"
" -o, --output=<file> if reading stdin, place the output into <file>\n"
" -q, --quiet suppress all messages\n"
- " -s, --dictionary-size=<bytes> set dictionary size limit in bytes [8MiB]\n"
+ " -s, --dictionary-size=<bytes> set dictionary size limit in bytes [8 MiB]\n"
" -t, --test test compressed file integrity\n"
" -v, --verbose be verbose (a 2nd -v gives more)\n"
" -1 .. -9 set compression level [default 6]\n"
@@ -117,7 +117,8 @@ static void show_help( void )
"The bidimensional parameter space of LZMA can't be mapped to a linear\n"
"scale optimal for all files. If your files are large, very repetitive,\n"
"etc, you may need to use the --match-length and --dictionary-size\n"
- "options directly to achieve optimal performance.\n"
+ "options directly to achieve optimal performance. For example, -9m64\n"
+ "usually compresses executables more (and faster) than -9.\n"
"\nExit status: 0 for a normal exit, 1 for environmental problems (file\n"
"not found, invalid flags, I/O errors, etc), 2 to indicate a corrupt or\n"
"invalid input file, 3 for an internal consistency error (eg, bug) which\n"