summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 14:46:41 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 14:46:41 +0000
commitab7779640d71d7925967cf357318819d1c064386 (patch)
tree88154625c96e5e4e389d228a016a72a4b50f57a0 /debian/rules
parentMerging upstream version 1.4~rc1. (diff)
downloadpdlzip-ab7779640d71d7925967cf357318819d1c064386.tar.xz
pdlzip-ab7779640d71d7925967cf357318819d1c064386.zip
Adding debian version 1.4~rc1-1.debian/1.4_rc1-1
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 10 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index d69544a..e0e4d5d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,8 +6,15 @@
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/pdlzip
-override_dh_strip:
- dh_strip --dbg-package=pdlzip-dbg
+ # alernative handling
+ mv debian/pdlzip/usr/bin/pdlzip debian/pdlzip/usr/bin/lzip.public-domain
+ mv debian/pdlzip/usr/share/man/man1/pdlzip.1 debian/pdlzip/usr/share/man/man1/lzip.public-domain.1
+
+ ln -s /usr/bin/lzip.public-domain debian/pdlzip/usr/bin/pdlzip
+ ln -s /usr/share/man/man1/lzip.public-domain.1.gz debian/pdlzip/usr/share/man/man1/pdlzip.1.gz
override_dh_builddeb:
- dh_builddeb -- -Zxz -z9
+ dh_builddeb -- -Zxz
+
+override_dh_strip:
+ dh_strip --dbg-package=pdlzip-dbg