summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile47
1 files changed, 6 insertions, 41 deletions
diff --git a/Makefile b/Makefile
index e68b94c..d6626b5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,3 @@
-# This file is part of orator
-# https://github.com/sdispater/orator
-
-# Licensed under the MIT license:
-# http://www.opensource.org/licenses/MIT-license
-# Copyright (c) 2015 Sébastien Eustace
-
-PENDULUM_RELEASE := $$(sed -n -E "s/VERSION = \"(.+)\"/\1/p" pendulum/version.py)
# lists all available targets
list:
@@ -16,38 +8,11 @@ list:
# required for list
no_targets__:
-# install all dependencies
-setup: setup-python
-
-# test your application (tests in the tests/ directory)
-test:
- @py.test --cov=pendulum --cov-config .coveragerc tests/ -sq
-
-linux_release: wheels_x64 wheels_i686
-
-release: wheels_x64 wheels_i686 wheel
-
-publish:
- @poetry publish --no-build
-
-tar:
- python setup.py sdist --formats=gztar
-
-wheel:
- @poetry build -v
-
-wheels_x64: build_wheels_x64
-
-wheels_i686: build_wheels_i686
-
-build_wheels_x64:
- docker pull quay.io/pypa/manylinux1_x86_64
- docker run --rm -v `pwd`:/io quay.io/pypa/manylinux1_x86_64 /io/build-wheels.sh
+lint-rust:
+ cd rust && cargo fmt --all -- --check
+ cd rust && cargo clippy --tests -- -D warnings
-build_wheels_i686:
- docker pull quay.io/pypa/manylinux1_i686
- docker run --rm -v `pwd`:/io quay.io/pypa/manylinux1_i686 /io/build-wheels.sh
-# run tests against all supported python versions
-tox:
- @tox
+format-rust:
+ cd rust && cargo fmt --all
+ cd rust && cargo clippy --tests --fix --allow-dirty -- -D warnings