summaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
new file mode 100644
index 0000000..0d76a89
--- /dev/null
+++ b/rust/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "_pendulum"
+version = "3.0.0"
+edition = "2021"
+
+[lib]
+name = "_pendulum"
+crate-type = ["cdylib", "rlib"]
+
+[profile.release]
+lto = "fat"
+codegen-units = 1
+strip = true
+overflow-checks = false
+
+[dependencies]
+pyo3 = { version = "0.19.0", features = ["extension-module", "generate-import-lib"] }
+mimalloc = { version = "0.1.39", optional = true, default-features = false }
+
+[features]
+extension-module = ["pyo3/extension-module"]
+default = ["mimalloc"]