summaryrefslogtreecommitdiffstats
path: root/debian/patches/0001-Change-dependencies-and-rename-entrypoint.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-Change-dependencies-and-rename-entrypoint.patch')
-rw-r--r--debian/patches/0001-Change-dependencies-and-rename-entrypoint.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/0001-Change-dependencies-and-rename-entrypoint.patch b/debian/patches/0001-Change-dependencies-and-rename-entrypoint.patch
new file mode 100644
index 0000000..e23577c
--- /dev/null
+++ b/debian/patches/0001-Change-dependencies-and-rename-entrypoint.patch
@@ -0,0 +1,33 @@
+From: Lennart Weller <lhw@ring0.de>
+Date: Fri, 8 May 2020 10:28:38 +0200
+Subject: Change dependencies and rename entrypoint
+
+diff -Naurp pgcli.orig/setup.py pgcli/setup.py
+--- pgcli.orig/setup.py
++++ pgcli/setup.py
+@@ -6,7 +6,7 @@ from pgcli import __version__
+ description = "CLI for Postgres Database. With auto-completion and syntax highlighting."
+
+ install_requirements = [
+- "pgspecial>=1.11.8",
++ "pgspecial>=1.9",
+ "click >= 4.1",
+ "Pygments >= 2.0", # Pygments has to be Capitalcased. WTF?
+ # We still need to use pt-2 unless pt-3 released on Fedora32
+@@ -16,7 +16,6 @@ install_requirements = [
+ "sqlparse >=0.3.0,<0.5",
+ "configobj >= 5.0.6",
+ "pendulum>=2.1.0",
+- "cli_helpers[styles] >= 2.0.0",
+ ]
+
+
+@@ -43,7 +42,7 @@ setup(
+ python_requires=">=3.6",
+ entry_points="""
+ [console_scripts]
+- pgcli=pgcli.main:cli
++ console=pgcli.main:cli
+ """,
+ classifiers=[
+ "Intended Audience :: Developers",