summaryrefslogtreecommitdiffstats
path: root/testing/resources
diff options
context:
space:
mode:
Diffstat (limited to 'testing/resources')
-rw-r--r--testing/resources/python3_hooks_repo/.pre-commit-hooks.yaml1
-rw-r--r--testing/resources/python_hooks_repo/foo.py2
-rw-r--r--testing/resources/python_hooks_repo/setup.py2
-rw-r--r--testing/resources/python_venv_hooks_repo/foo.py2
-rw-r--r--testing/resources/python_venv_hooks_repo/setup.py2
5 files changed, 8 insertions, 1 deletions
diff --git a/testing/resources/python3_hooks_repo/.pre-commit-hooks.yaml b/testing/resources/python3_hooks_repo/.pre-commit-hooks.yaml
index 2c23700..964cf83 100644
--- a/testing/resources/python3_hooks_repo/.pre-commit-hooks.yaml
+++ b/testing/resources/python3_hooks_repo/.pre-commit-hooks.yaml
@@ -2,5 +2,4 @@
name: Python 3 Hook
entry: python3-hook
language: python
- language_version: python3
files: \.py$
diff --git a/testing/resources/python_hooks_repo/foo.py b/testing/resources/python_hooks_repo/foo.py
index 9c4368e..40efde3 100644
--- a/testing/resources/python_hooks_repo/foo.py
+++ b/testing/resources/python_hooks_repo/foo.py
@@ -1,3 +1,5 @@
+from __future__ import annotations
+
import sys
diff --git a/testing/resources/python_hooks_repo/setup.py b/testing/resources/python_hooks_repo/setup.py
index 0559271..cff6cad 100644
--- a/testing/resources/python_hooks_repo/setup.py
+++ b/testing/resources/python_hooks_repo/setup.py
@@ -1,3 +1,5 @@
+from __future__ import annotations
+
from setuptools import setup
setup(
diff --git a/testing/resources/python_venv_hooks_repo/foo.py b/testing/resources/python_venv_hooks_repo/foo.py
index 9c4368e..40efde3 100644
--- a/testing/resources/python_venv_hooks_repo/foo.py
+++ b/testing/resources/python_venv_hooks_repo/foo.py
@@ -1,3 +1,5 @@
+from __future__ import annotations
+
import sys
diff --git a/testing/resources/python_venv_hooks_repo/setup.py b/testing/resources/python_venv_hooks_repo/setup.py
index 0559271..cff6cad 100644
--- a/testing/resources/python_venv_hooks_repo/setup.py
+++ b/testing/resources/python_venv_hooks_repo/setup.py
@@ -1,3 +1,5 @@
+from __future__ import annotations
+
from setuptools import setup
setup(