summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-02 10:57:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-02 10:58:30 +0000
commitd7174afe663e7612270f0ad2cf0d55edf986fb8b (patch)
tree026058a95cf8dcdb11b6aea5bd05ee3385416913
parentReleasing debian version 20211008-13. (diff)
downloadprogress-linux-metapackages-d7174afe663e7612270f0ad2cf0d55edf986fb8b.tar.xz
progress-linux-metapackages-d7174afe663e7612270f0ad2cf0d55edf986fb8b.zip
Merging upstream version 20221002.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGELOG.txt18
-rw-r--r--LICENSE.txt8
-rw-r--r--Makefile33
-rw-r--r--VERSION.txt2
-rw-r--r--man/Makefile4
-rw-r--r--man/man.in4
-rw-r--r--man/progress-linux-metapackages.7.rst4
7 files changed, 55 insertions, 18 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 6ce4600..62495d0 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,15 @@
+2022-10-02 Daniel Baumann <daniel.baumann@progress-linux.org>
+
+ * Releasing version 20221002.
+
+ [ Daniel Baumann ]
+ * Recreating changelog from git commits.
+ * Updating license with newer GPL-3 version containing https instead of http links.
+ * Updating comment headers in makefiles.
+ * Updating comment headers in makefiles.
+ * Updating copyright headers for 2022.
+ * Adding release and upload targets to makefile.
+
2021-01-01 Daniel Baumann <daniel.baumann@progress-linux.org>
* Releasing version 20211008.
@@ -23,7 +35,13 @@
[ Daniel Baumann ]
* Correcting package name typo in Makefile.
* Removing unnecessary trailing slash in manpage urls.
+ * Updating date and version in manpage.
2019-02-25 Daniel Baumann <daniel.baumann@progress-linux.org>
* Releasing version 20190225.
+
+ [ Daniel Baumann ]
+ * Adding Makefile.
+ * Adding LICENSE.txt.
+ * Adding manpages/progress-linux-metapackages.7.
diff --git a/LICENSE.txt b/LICENSE.txt
index 94a9ed0..f288702 100644
--- a/LICENSE.txt
+++ b/LICENSE.txt
@@ -1,7 +1,7 @@
GNU GENERAL PUBLIC LICENSE
Version 3, 29 June 2007
- Copyright (C) 2007 Free Software Foundation, Inc. <http://fsf.org/>
+ Copyright (C) 2007 Free Software Foundation, Inc. <https://fsf.org/>
Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.
@@ -645,7 +645,7 @@ the "copyright" line and a pointer to where the full notice is found.
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
+ along with this program. If not, see <https://www.gnu.org/licenses/>.
Also add information on how to contact you by electronic and paper mail.
@@ -664,11 +664,11 @@ might be different; for a GUI interface, you would use an "about box".
You should also get your employer (if you work as a programmer) or school,
if any, to sign a "copyright disclaimer" for the program, if necessary.
For more information on this, and how to apply and follow the GNU GPL, see
-<http://www.gnu.org/licenses/>.
+<https://www.gnu.org/licenses/>.
The GNU General Public License does not permit incorporating your program
into proprietary programs. If your program is a subroutine library, you
may consider it more useful to permit linking proprietary applications with
the library. If this is what you want to do, use the GNU Lesser General
Public License instead of this License. But first, please read
-<http://www.gnu.org/philosophy/why-not-lgpl.html>.
+<https://www.gnu.org/licenses/why-not-lgpl.html>.
diff --git a/Makefile b/Makefile
index b58c94e..61a6202 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,4 @@
-# Progress Linux metapackages
-
-# Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+# Copyright (C) 2010-2022 Daniel Baumann <daniel.baumann@progress-linux.org>
#
# SPDX-License-Identifier: GPL-3.0+
#
@@ -19,7 +17,10 @@
SHELL := sh -e
-PROJECT := progress-linux-metapackages
+PROJECT := progress-linux
+SOFTWARE := progress-linux-metapackages
+
+VERSION := $(shell cat VERSION.txt)
all: build
@@ -74,3 +75,27 @@ uninstall-man:
done
reinstall: clean uninstall build install
+
+distclean: clean
+ rm -rf $(SOFTWARE)-$(VERSION)
+
+release: distclean
+ git commit -a -s -S -m 'Releasing version $(VERSION).' || true
+ git tag -s -m 'Tagging version $(VERSION).' v$(VERSION) || true
+
+ mkdir -p $(SOFTWARE)-$(VERSION)
+ find . -mindepth 1 -maxdepth 1 -and -not -name ".git*" -and -not -name debian -and -not -name $(SOFTWARE)-$(VERSION) -exec cp \-a {} $(SOFTWARE)-$(VERSION) \;
+
+ for FORMAT in xz lzip; \
+ do \
+ EXTENSION=$$(echo $${FORMAT} | cut -b-2); \
+ tar --$${FORMAT} -cf ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} $(SOFTWARE)-$(VERSION); \
+ sha512sum ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} > ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sha512; \
+ gpg --default-key 0x3E6CA28DAAF8DD14 --armor -b ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}; \
+ mv ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.asc ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sig; \
+ done
+
+ rm -rf $(SOFTWARE)-$(VERSION)
+
+upload:
+ scp ../$(SOFTWARE)-$(VERSION).* get.progress-linux.org:/srv/get.progress-linux.org/packages/$(SOFTWARE)/upstream
diff --git a/VERSION.txt b/VERSION.txt
index 202e0fe..9bab13a 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20211008
+20221002
diff --git a/man/Makefile b/man/Makefile
index 42a10c8..e0395ff 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -1,6 +1,4 @@
-# Progress Linux metapackages
-
-# Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+# Copyright (C) 2010-2022 Daniel Baumann <daniel.baumann@progress-linux.org>
#
# SPDX-License-Identifier: GPL-3.0+
#
diff --git a/man/man.in b/man/man.in
index b602b75..03d10e6 100644
--- a/man/man.in
+++ b/man/man.in
@@ -1,6 +1,4 @@
-.\" Progress Linux metapackages
-
-.\" Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+.\" Copyright (C) 2010-2022 Daniel Baumann <daniel.baumann@progress-linux.org>
.\"
.\" SPDX-License-Identifier: GPL-3.0+
.\"
diff --git a/man/progress-linux-metapackages.7.rst b/man/progress-linux-metapackages.7.rst
index 6eb8603..22db849 100644
--- a/man/progress-linux-metapackages.7.rst
+++ b/man/progress-linux-metapackages.7.rst
@@ -1,6 +1,4 @@
-.. Progress Linux metapackages
-
-.. Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+.. Copyright (C) 2010-2022 Daniel Baumann <daniel.baumann@progress-linux.org>
..
.. SPDX-License-Identifier: GPL-3.0+
..