summaryrefslogtreecommitdiffstats
path: root/man
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-10-08 12:10:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-10-08 17:19:22 +0000
commit8893340b25a2b56c2155df67266b786a2dd6d282 (patch)
treece27195c73b67b0b660c71f39e0fc2016b16e491 /man
parentReleasing debian version 20210101-2. (diff)
downloadprogress-linux-metapackages-8893340b25a2b56c2155df67266b786a2dd6d282.tar.xz
progress-linux-metapackages-8893340b25a2b56c2155df67266b786a2dd6d282.zip
Merging upstream version 20211008.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'man')
-rw-r--r--man/Makefile59
-rw-r--r--man/man.in19
-rw-r--r--man/progress-linux-metapackages.7.rst80
3 files changed, 158 insertions, 0 deletions
diff --git a/man/Makefile b/man/Makefile
new file mode 100644
index 0000000..42a10c8
--- /dev/null
+++ b/man/Makefile
@@ -0,0 +1,59 @@
+# Progress Linux metapackages
+
+# Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Depends: python3-docutils
+
+RST2MAN = rst2man \
+ --no-datestamp \
+ --no-generator \
+ --strict \
+ --strip-comments \
+ --tab-width=4 \
+ --verbose
+
+VERSION := $(shell cat ../VERSION.txt)
+
+SHELL := sh -e
+
+all: build
+
+build: man
+
+rebuild: clean build
+
+man: man.in *.rst
+ @echo -n "Creating manpages... "
+
+ @for FILE in *.rst; \
+ do \
+ cp man.in $$(basename $${FILE} .rst); \
+ $(RST2MAN) $${FILE} | \
+ sed -e '/^.\\" Man page generated/d' \
+ -e '/^.\\" Generated by/d' \
+ -e "s|^\(.TH .*\) \(\"\" \"\"\) |\1 $${VERSION} progress-linux-metapackages |" \
+ >> $$(basename $${FILE} .rst); \
+ echo -n "."; \
+ done
+
+ @echo " done."
+
+clean:
+ rm -f *.[0-9]
+
+.PHONY: all clean build rebuild man
diff --git a/man/man.in b/man/man.in
new file mode 100644
index 0000000..b602b75
--- /dev/null
+++ b/man/man.in
@@ -0,0 +1,19 @@
+.\" Progress Linux metapackages
+
+.\" Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+.\"
+.\" SPDX-License-Identifier: GPL-3.0+
+.\"
+.\" This program is free software: you can redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as published by
+.\" the Free Software Foundation, either version 3 of the License, or
+.\" (at your option) any later version.
+.\"
+.\" This program is distributed in the hope that it will be useful,
+.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License
+.\" along with this program. If not, see <https://www.gnu.org/licenses/>.
+.\"
diff --git a/man/progress-linux-metapackages.7.rst b/man/progress-linux-metapackages.7.rst
new file mode 100644
index 0000000..6eb8603
--- /dev/null
+++ b/man/progress-linux-metapackages.7.rst
@@ -0,0 +1,80 @@
+.. Progress Linux metapackages
+
+.. Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+..
+.. SPDX-License-Identifier: GPL-3.0+
+..
+.. This program is free software: you can redistribute it and/or modify
+.. it under the terms of the GNU General Public License as published by
+.. the Free Software Foundation, either version 3 of the License, or
+.. (at your option) any later version.
+..
+.. This program is distributed in the hope that it will be useful,
+.. but WITHOUT ANY WARRANTY; without even the implied warranty of
+.. MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.. GNU General Public License for more details.
+..
+.. You should have received a copy of the GNU General Public License
+.. along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+===========================
+progress-linux-metapackages
+===========================
+
+------------------------------------
+Package selection for Progress Linux
+------------------------------------
+
+:manual section: 7
+:manual group: Progress Linux
+
+Description
+===========
+
+Progress Linux is a Debian derivative distribution focused on system
+integration.
+
+The following main metapackages are available:
+
+progress-linux-base-system
+--------------------------
+
+| The Progress Linux Base System includes packages that provide a reasonably
+| small but not too limited character-mode system.
+
+progress-linux-container-server
+-------------------------------
+
+| The Progress Linux Container Server is a complete system configured as a
+| server for systemd-nspawn based containers.
+
+progress-linux-gnome-desktop
+----------------------------
+
+| The Progress Linux GNOME Desktop is a complete system configured as a desktop
+| for power users.
+
+Development
+===========
+
+Bug reports, feature requests, help, patches, support and everything else are
+welcome on the Progress Linux Maintainers Mailing List
+(https://lists.progress-linux.org/listinfo/maintainers).
+
+Please base patches against the 'next' Git branch using common sense
+(https://www.kernel.org/doc/Documentation/SubmittingPatches).
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System
+(https://bugs.debian.org).
+
+Homepage
+========
+
+More information about Progress Linux can be found on the homepage
+(https://progress-linux.org).
+
+Authors
+=======
+
+progress-linux-metapackages were written by Daniel Baumann
+<daniel.baumann@progress-linux.org> and others.