summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-26 04:10:02 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-26 04:10:02 +0000
commit227038a454943a075c51b60988c53f77a605fa10 (patch)
tree15d438e5519a2ba9ee7ba8c6f864bbc597ea33b5 /setup.py
parentInitial commit. (diff)
downloadptpython-227038a454943a075c51b60988c53f77a605fa10.tar.xz
ptpython-227038a454943a075c51b60988c53f77a605fa10.zip
Adding upstream version 3.0.16.upstream/3.0.16
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py51
1 files changed, 51 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..dbbe55b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,51 @@
+#!/usr/bin/env python
+import os
+import sys
+
+from setuptools import find_packages, setup
+
+with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f:
+ long_description = f.read()
+
+
+setup(
+ name="ptpython",
+ author="Jonathan Slenders",
+ version="3.0.16",
+ url="https://github.com/prompt-toolkit/ptpython",
+ description="Python REPL build on top of prompt_toolkit",
+ long_description=long_description,
+ packages=find_packages("."),
+ install_requires=[
+ "appdirs",
+ "importlib_metadata;python_version<'3.8'",
+ "jedi>=0.16.0",
+ # Use prompt_toolkit 3.0.16, because of the `DeduplicateCompleter`.
+ "prompt_toolkit>=3.0.16,<3.1.0",
+ "pygments",
+ "black",
+ ],
+ python_requires=">=3.6",
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python",
+ ],
+ entry_points={
+ "console_scripts": [
+ "ptpython = ptpython.entry_points.run_ptpython:run",
+ "ptipython = ptpython.entry_points.run_ptipython:run",
+ "ptpython%s = ptpython.entry_points.run_ptpython:run" % sys.version_info[0],
+ "ptpython%s.%s = ptpython.entry_points.run_ptpython:run"
+ % sys.version_info[:2],
+ "ptipython%s = ptpython.entry_points.run_ptipython:run"
+ % sys.version_info[0],
+ "ptipython%s.%s = ptpython.entry_points.run_ptipython:run"
+ % sys.version_info[:2],
+ ]
+ },
+ extras_require={"ptipython": ["ipython"]}, # For ptipython, we need to have IPython
+)