summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2023-12-17 10:46:44 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2023-12-17 10:46:44 +0000
commit70b47719c91522ab53abc763eb6da3b62c1a00c9 (patch)
treedb7906833e1af835fb2addf0c220f00904969cd7 /setup.py
parentReleasing debian version 3.0.23-3. (diff)
downloadptpython-70b47719c91522ab53abc763eb6da3b62c1a00c9.tar.xz
ptpython-70b47719c91522ab53abc763eb6da3b62c1a00c9.zip
Merging upstream version 3.0.25.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 10 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 18d2911..bc1241b 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,7 @@ with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f:
setup(
name="ptpython",
author="Jonathan Slenders",
- version="3.0.23",
+ version="3.0.25",
url="https://github.com/prompt-toolkit/ptpython",
description="Python REPL build on top of prompt_toolkit",
long_description=long_description,
@@ -21,12 +21,13 @@ setup(
"appdirs",
"importlib_metadata;python_version<'3.8'",
"jedi>=0.16.0",
- # Use prompt_toolkit 3.0.28, because of cursor shape support.
- "prompt_toolkit>=3.0.28,<3.1.0",
+ # Use prompt_toolkit 3.0.34, because of `OneStyleAndTextTuple` import.
+ "prompt_toolkit>=3.0.34,<3.1.0",
"pygments",
],
python_requires=">=3.7",
classifiers=[
+ "License :: OSI Approved :: BSD License",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.7",
@@ -39,12 +40,14 @@ setup(
"ptpython = ptpython.entry_points.run_ptpython:run",
"ptipython = ptpython.entry_points.run_ptipython:run",
"ptpython%s = ptpython.entry_points.run_ptpython:run" % sys.version_info[0],
- "ptpython%s.%s = ptpython.entry_points.run_ptpython:run"
- % sys.version_info[:2],
+ "ptpython{}.{} = ptpython.entry_points.run_ptpython:run".format(
+ *sys.version_info[:2]
+ ),
"ptipython%s = ptpython.entry_points.run_ptipython:run"
% sys.version_info[0],
- "ptipython%s.%s = ptpython.entry_points.run_ptipython:run"
- % sys.version_info[:2],
+ "ptipython{}.{} = ptpython.entry_points.run_ptipython:run".format(
+ *sys.version_info[:2]
+ ),
]
},
extras_require={