summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 17 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index dbbe55b..a54da35 100644
--- a/setup.py
+++ b/setup.py
@@ -11,24 +11,25 @@ with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f:
setup(
name="ptpython",
author="Jonathan Slenders",
- version="3.0.16",
+ version="3.0.26",
url="https://github.com/prompt-toolkit/ptpython",
description="Python REPL build on top of prompt_toolkit",
long_description=long_description,
packages=find_packages("."),
+ package_data={"ptpython": ["py.typed"]},
install_requires=[
"appdirs",
"importlib_metadata;python_version<'3.8'",
"jedi>=0.16.0",
- # Use prompt_toolkit 3.0.16, because of the `DeduplicateCompleter`.
- "prompt_toolkit>=3.0.16,<3.1.0",
+ # Use prompt_toolkit 3.0.34, because of `OneStyleAndTextTuple` import.
+ "prompt_toolkit>=3.0.34,<3.1.0",
"pygments",
- "black",
],
- python_requires=">=3.6",
+ python_requires=">=3.7",
classifiers=[
+ "License :: OSI Approved :: BSD License",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3 :: Only",
@@ -39,13 +40,18 @@ setup(
"ptpython = ptpython.entry_points.run_ptpython:run",
"ptipython = ptpython.entry_points.run_ptipython:run",
"ptpython%s = ptpython.entry_points.run_ptpython:run" % sys.version_info[0],
- "ptpython%s.%s = ptpython.entry_points.run_ptpython:run"
- % sys.version_info[:2],
+ "ptpython{}.{} = ptpython.entry_points.run_ptpython:run".format(
+ *sys.version_info[:2]
+ ),
"ptipython%s = ptpython.entry_points.run_ptipython:run"
% sys.version_info[0],
- "ptipython%s.%s = ptpython.entry_points.run_ptipython:run"
- % sys.version_info[:2],
+ "ptipython{}.{} = ptpython.entry_points.run_ptipython:run".format(
+ *sys.version_info[:2]
+ ),
]
},
- extras_require={"ptipython": ["ipython"]}, # For ptipython, we need to have IPython
+ extras_require={
+ "ptipython": ["ipython"], # For ptipython, we need to have IPython
+ "all": ["black"], # Black not always possible on PyPy
+ },
)