summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 08:55:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 08:55:51 +0000
commitb4ea5a3722487b0d46f197158c46229405b1048f (patch)
tree301b9af97ef5b1b5f72d6e5ef32aba3b93b73c39 /pyproject.toml
parentInitial commit. (diff)
downloadpydantic-extra-types-b4ea5a3722487b0d46f197158c46229405b1048f.tar.xz
pydantic-extra-types-b4ea5a3722487b0d46f197158c46229405b1048f.zip
Adding upstream version 2.6.0.upstream/2.6.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml120
1 files changed, 120 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..d713e4d
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,120 @@
+[build-system]
+requires = ['hatchling']
+build-backend = 'hatchling.build'
+
+[tool.hatch.version]
+path = 'pydantic_extra_types/__init__.py'
+
+[project]
+name = 'pydantic-extra-types'
+description = 'Extra Pydantic types.'
+authors = [
+ {name = 'Samuel Colvin', email = 's@muelcolvin.com'},
+ {name = 'Yasser Tahiri', email = 'hello@yezz.me'},
+]
+license = 'MIT'
+readme = 'README.md'
+classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
+ 'Programming Language :: Python :: 3.12',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: Unix',
+ 'Operating System :: POSIX :: Linux',
+ 'Environment :: Console',
+ 'Environment :: MacOS X',
+ 'Framework :: Pydantic',
+ 'Framework :: Pydantic :: 2',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Internet',
+]
+requires-python = '>=3.8'
+dependencies = [
+ 'pydantic>=2.5.2',
+]
+dynamic = ['version']
+
+[project.optional-dependencies]
+all = [
+ 'phonenumbers>=8,<9',
+ 'pycountry>=23',
+ 'python-ulid>=1,<2; python_version<"3.9"',
+ 'python-ulid>=1,<3; python_version>="3.9"',
+ 'pendulum>=3.0.0,<4.0.0'
+]
+
+[project.urls]
+Homepage = 'https://github.com/pydantic/pydantic-extra-types'
+Source = 'https://github.com/pydantic/pydantic-extra-types'
+Changelog = 'https://github.com/pydantic/pydantic-extra-types/releases'
+Documentation = 'https://docs.pydantic.dev/latest/'
+
+[tool.ruff.lint.pyupgrade]
+keep-runtime-typing = true
+
+[tool.ruff]
+line-length = 120
+target-version = 'py38'
+
+[tool.ruff.lint]
+extend-select = ['Q', 'RUF100', 'C90', 'UP', 'I']
+flake8-quotes = {inline-quotes = 'single', multiline-quotes = 'double'}
+isort = { known-first-party = ['pydantic_extra_types', 'tests'] }
+mccabe = { max-complexity = 14 }
+pydocstyle = { convention = 'google' }
+
+[tool.ruff.format]
+quote-style = 'single'
+
+[tool.ruff.lint.per-file-ignores]
+'pydantic_extra_types/color.py' = ['E741']
+
+[tool.coverage.run]
+source = ['pydantic_extra_types']
+branch = true
+context = '${CONTEXT}'
+
+[tool.coverage.paths]
+source = [
+ 'pydantic_extra_types/',
+ '/Users/runner/work/pydantic-extra-types/pydantic-extra-types/pydantic_extra_types/',
+ 'D:\a\pydantic-extra-types\pydantic-extra-types\pydantic_extra_types',
+]
+
+[tool.coverage.report]
+precision = 2
+fail_under = 100
+show_missing = true
+skip_covered = true
+exclude_lines = [
+ 'pragma: no cover',
+ 'raise NotImplementedError',
+ 'if TYPE_CHECKING:',
+ '@overload',
+]
+
+
+[tool.mypy]
+strict = true
+plugins = 'pydantic.mypy'
+
+[tool.pytest.ini_options]
+filterwarnings = [
+ 'error',
+ # This ignore will be removed when pycountry will drop py36 & support py311
+ 'ignore:::pkg_resources',
+]
+
+# configuring https://github.com/pydantic/hooky
+[tool.hooky]
+reviewers = ['yezz123', 'Kludex']
+require_change_file = false