summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2022-06-19 07:06:23 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2022-06-19 07:06:34 +0000
commit5af1e7262d704ec79cc40ecc2f61bcd8d1dd02d7 (patch)
tree5f908593917c99e6f9ea8c65861a51e30dbfa19c /pyproject.toml
parentReleasing debian version 0.1.2-4. (diff)
downloadpydyf-5af1e7262d704ec79cc40ecc2f61bcd8d1dd02d7.tar.xz
pydyf-5af1e7262d704ec79cc40ecc2f61bcd8d1dd02d7.zip
Merging upstream version 0.2.0.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5a88369..a89cea0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,7 +8,7 @@ description = 'A low-level PDF generator.'
keywords = ['pdf', 'generator']
authors = [{name = 'CourtBouillon', email = 'contact@courtbouillon.org'}]
maintainers = [{name = 'CourtBouillon', email = 'contact@courtbouillon.org'}]
-requires-python = '>=3.6'
+requires-python = '>=3.7'
readme = {file = 'README.rst', content-type = 'text/x-rst'}
license = {file = 'LICENSE'}
classifiers = [
@@ -19,10 +19,10 @@ classifiers = [
'Programming Language :: Python',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3 :: Only',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
]
@@ -38,13 +38,13 @@ Donation = 'https://opencollective.com/courtbouillon'
[project.optional-dependencies]
doc = ['sphinx', 'sphinx_rtd_theme']
-test = ['pytest', 'pytest-cov', 'pytest-flake8', 'pytest-isort', 'coverage[toml]', 'pillow']
+test = ['pytest', 'pytest-xdist', 'pytest-flake8', 'pytest-isort', 'pytest-cov', 'coverage[toml]', 'pillow']
[tool.flit.sdist]
exclude = ['.*']
[tool.pytest.ini_options]
-addopts = '--isort --flake8 --cov --no-cov-on-fail'
+addopts = '--isort --flake8 --numprocesses=auto'
[tool.coverage.run]
branch = true