summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-07-01 10:01:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-07-01 10:01:22 +0000
commiteec8faedb2ef23a991d9e2faa505c40e6abe4466 (patch)
treecd11b74bd37afae30a836fc7a7383de6704ca161 /Makefile.in
parentAdding debian version 4.1.4-3. (diff)
downloadsamhain-eec8faedb2ef23a991d9e2faa505c40e6abe4466.tar.xz
samhain-eec8faedb2ef23a991d9e2faa505c40e6abe4466.zip
Removing changes outside of debian directory.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in31
1 files changed, 18 insertions, 13 deletions
diff --git a/Makefile.in b/Makefile.in
index 409b003..684e92b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -54,7 +54,7 @@ selectconfig = @selectconfig@
top_builddir = .
INSTALL = @INSTALL@
-INSTALL_PROGRAM = @INSTALL@ -m 700
+INSTALL_PROGRAM = @INSTALL@ -s -m 700
INSTALL_SHELL = @INSTALL@ -m 700
INSTALL_DATA = @INSTALL@ -m 600
INSTALL_MAN = @INSTALL@ -m 644
@@ -229,7 +229,7 @@ PROGRAMS = $(SETPWD) $(STEGIN) $(SAMHAIN) $(YULECTL) $(SADMIN)
#
#----------------------------------------------------------
-all: $(top_srcdir)/depend.sum $(SETPWD) $(STEGIN) $(SAMHAIN) $(YULECTL)
+all: $(top_srcdir)/depend.sum $(SETPWD) $(STEGIN) $(SAMHAIN) $(YULECTL) sstrip
#----------------------------------------------------------
@@ -512,7 +512,7 @@ uninstall-boot: samhain-install.sh
#
-install-program: $(PROGRAMS)
+install-program: $(PROGRAMS) sstrip
@$(mkinstalldirs) $(DESTDIR)$(sbindir)
@if test x$(mytmpdir) != x; then \
$(mkinstalldirs) $(DESTDIR)$(mytmpdir); \
@@ -525,6 +525,8 @@ install-program: $(PROGRAMS)
echo " $(INSTALL_PROGRAM) $$p $$target"; \
$(INSTALL_PROGRAM) $$p $$target; \
chmod 0700 $$target; \
+ echo " ./sstrip $$target"; \
+ ./sstrip $$target; \
else \
echo " $(INSTALL_SHELL) $$p $$target"; \
$(INSTALL_SHELL) $$p $$target; \
@@ -1254,26 +1256,29 @@ exepack_fill: $(srcsrc)/exepack_fill.c minilzo.o exepack
echo "$(LINK) exepack_fill.o minilzo.o"; \
$(LINK) exepack_fill.o minilzo.o
-samhain.pk: $(SAMHAIN) exepack exepack_fill
+samhain.pk: $(SAMHAIN) exepack exepack_fill sstrip
@echo "cp ./$(SAMHAIN) ./samhain.pk.data"; \
- cp ./$(SAMHAIN) ./samhain.pk.data
+ cp ./$(SAMHAIN) ./samhain.pk.data; \
echo "strip ./samhain.pk.data"; \
- strip ./samhain.pk.data > /dev/null 2>&1 || echo "... is already stripped"
- test -f exepack.out && rm exepack.out
+ strip ./samhain.pk.data > /dev/null 2>&1 || echo "... is already stripped"; \
+ echo "./sstrip ./samhain.pk.data"; \
+ ./sstrip ./samhain.pk.data > /dev/null 2>&1 || echo "sstrip returned false"; \
+ test -f exepack.out && rm exepack.out; \
echo "./exepack_fill exepack samhain.pk.data exepack.out"; \
- ./exepack_fill exepack samhain.pk.data exepack.out
- chmod +x exepack.out
+ ./exepack_fill exepack samhain.pk.data exepack.out; \
+ chmod +x exepack.out; \
echo "strip exepack.out"; \
- strip exepack.out > /dev/null 2>&1 || echo "... is already stripped"
+ strip exepack.out > /dev/null 2>&1 || echo "... is already stripped"; \
+ ./sstrip exepack.out > /dev/null 2>&1 || echo "sstrip returned false"; \
echo "mv exepack.out samhain.pk"; \
rm -f samhain.pk; mv exepack.out samhain.pk
samhain-packed: $(SAMHAIN) samhain_setpwd
@echo "samhain_setpwd samhain new $(CLIENTPASSWD)"; \
- samhain_setpwd samhain new $(CLIENTPASSWD)
+ samhain_setpwd samhain new $(CLIENTPASSWD); \
echo "rm -f samhain; mv samhain.new samhain"; \
- rm -f samhain; mv samhain.new samhain
- $(MAKE) samhain.pk
+ rm -f samhain; mv samhain.new samhain; \
+ $(MAKE) samhain.pk; \
echo "rm -f samhain; mv samhain.pk samhain"; \
rm -f samhain; mv samhain.pk samhain