summaryrefslogtreecommitdiffstats
path: root/docs/Changelog
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Changelog')
-rw-r--r--docs/Changelog147
1 files changed, 144 insertions, 3 deletions
diff --git a/docs/Changelog b/docs/Changelog
index c29cefe..d7e3594 100644
--- a/docs/Changelog
+++ b/docs/Changelog
@@ -1,4 +1,145 @@
-4.1.4:
+4.4.10:
+ * fix for (very minor) memleak in sh_unix.c: sh_check_rotated_log()
+ * fix for memleak in sh_files.c: sh_files_checkdir(), not all cases for
+ scandir() covered (issue reported by T. Greulich)
+
+4.4.9:
+ * fix for double newline stripping when reading from database
+
+4.4.8 (01-05-2022):
+ * new server option Alias=alias@hostname (based on
+ patch by A. Hofland)
+
+4.4.7 (07-03-2022):
+ * fix compile error on MacOS
+ * disable dnmalloc for gcc 11 (regexec does not work)
+ * fix minor compile issues with gcc 11.2
+ * fix problem with login/logout monitoring on MacOS (reported
+ by Peter)
+ * fix problem caused by switch from pubkey.gpg to pubkey.kbx
+ (reported by A. Hofland)
+
+4.4.6 (05-10-2021):
+ * fix Debian 10 compile problem in dnmalloc (mallinfo2),
+ reported by A. Hofland and others
+ * fix compile problem on Ubuntu 20 with 'make deb'
+ (Debian optimization CFLAGS clash with ASM for Tiger)
+ * fix 'make deb' issue when compiling as client
+ (reported by A. Hofland)
+ * fix issue with inotify (reported by Thorsten)
+
+4.4.5 (01-07-2021):
+ * fix a memory leak introduced in 4.4.4
+
+4.4.4 (30-06-2021):
+ * fix more gcc 10 compiler warnings
+ * fix bug with signify-openbsd in client/server setup (reported
+ by Sdoba)
+ * patch by K. Hacene for reproducible database generation
+ * fix recognition of invalid compiler options in configure.ac
+
+4.4.3 (31-10-2020):
+ * allow console logging to a unix domain socket
+ * fix spurious cppcheck warnings
+ * fix gcc 10 compiler warning in sh_audit.c
+ * fix gcc 10 compiler warning in sh_ipvx.c
+ * fix gcc 10 compile problem in sh_tiger1_64.c
+ * fix gcc 10 compiler warning in sh_portcheck.c
+
+4.4.2 (01-08-2020):
+ * re-enabled reading options from option group [samhain] in my.cnf
+ * fix server install in configure.ac: samhainadmin.pl <-> ..-gpg.pl, ..-sig.pl
+ * add more verbosity to portable binary installer, fix minor issues
+
+4.4.1 (27-02-2020):
+ * fix compatibility problem with older (version 2.0.x) GnuPG
+
+4.4.0 (31-10-2019):
+ * support for OpenBSD signify as alternative to GnuPG
+
+4.3.3 (11-07-2019):
+ * fix broken 'make deb' makefile target
+ * eliminate obsolete 'sstrip' utility
+ * systemd support
+ * fix broken rpm specfile (patch by Franky Van L.)
+ * fix broken mysql init script
+ * fix some issues with link-time optimisation (option -flto with
+ recent gcc versions)
+ * fix compiler warning in sh_prelude.c
+ * add patch (by Kamel H.) to init for alternative root fs)
+
+4.3.2 (07-01-2019):
+ * fix compile failure on OpenBSD (reported by Mithrond)
+
+4.3.1 (25-09.2018):
+ * fix compile failure on non-Linux systems (reported by Romain and Tim)
+ * provide more information for error message about bad baseline
+ database file (issue raised by Romain)
+
+4.3.0 (10-09-2018):
+ * add support for /etc/subuid, /etc/subgid maps
+ * fix compiler warning on Ubuntu 18.04
+
+4.2.4 (21-12-2017):
+ * fix 'clobbered by..' compiler warning is src/sh_portcheck.c
+ * fix compiler warning because of deprecated _BSD_SOURCE macro
+ * fix 'make deb' for Debian stretch (reported by Alasdair)
+ * add RPM spec file patch for SLES12 (by Pirmin)
+ * better fix for RPMTOP detection
+ * fix missing entry for yuleadmin.pl in RPM spec file
+ * fix bug in static dns resolver (reported by Piotr G.)
+
+4.2.3 (31-10-2017):
+ * fix order of search directories for 'make rpm' (issue reported by
+ Z. Drableg)
+
+4.2.2 (03-07-2017):
+ * fix bug with PortCheckSkip: for any given port, only first interface
+ specified in config is checked (reported by A. Hofland)
+ * fix PortCheck bug that occasionally causes spurious detections of
+ open ports (patch by A. Hofland)
+ * add success/failure message for closing baseline database at init
+
+4.2.1 (06-04-2017):
+ * fix for broken SetSocketPassword authentication
+ (reported by Todd Stansell)
+ * fix compile issue on Solaris 11 (reported by Rolf)
+ * fix alignment problem with semget() (reported by Rolf)
+ * fix dependency on chkconfig package on Redhat/CentOS: search
+ /etc/init.d/functions also under /etc/rc.d/init.d/functions
+ (issue reported by Ernie)
+ * fix build issue with musl libc (report & patch by A. Kuster)
+ * fix case sensitivity (tcp vs TCP, udp vs UDP) in portcheck
+ directives (reported by A. Hofland)
+ * fix documentation typo ('make deploy-install' ->
+ 'make install-deploy', reported by Ben)
+ * fix dsys/funcINSTALL: proper error message if no binary
+ packages built yet (problem reported by Ben)
+ * fix install-data: make datadir chmod conditional and
+ align with documentation
+
+4.2.0 (31-10-2016):
+ * fix handle tracefs (permission for stat denied) when running
+ suidcheck without root privilege (for testing)
+ * fix compiler warnings on gcc 6.2
+ * fix incorrect mandir option in Install.sh (reported by David)
+ * add option 'SetAuditdFlags = r|w|x|a' to (re-)define flags supplied
+ to auditd (request by David)
+ * fix minor bug in error message (tf_trust_errfile needs copy to
+ keep relevant value).
+ * fix SH_DEADFILE (too big, some architectures have nlink_t
+ as uint16, e.g. FreeBSD).
+ * add portcheck option 'PortCheckDevice = device' to monitor a
+ device regardless of address assigned to it (patch by A. Hofland, plus
+ some additions)
+ * fix case sensitivity of severity/class options (issue raised by
+ A. Hofland).
+ * clarify restrictions for ProcessCheckPSArg (user manual)
+
+4.1.5 (09-08-2016):
+ * fix memory leak in server (reported by C. Doerr).
+
+4.1.4 (02-06-2016):
* fix problems with wildcard pattern re-evaluation (reported by
A. Ansari):
- not stored if no match at startup
@@ -487,7 +628,7 @@
* sh_mem.c: fix deadlock in debug-only code
* Evaluate glob patterns for each run of file check
* Add compile option to disable compiling with SSP
- * Run SUID check in seperate thread
+ * Run SUID check in separate thread
* By default disable scanning ..namedfork/rsrc (deprecated by Apple)
2.5.10 (12-10-2009):
@@ -1394,7 +1535,7 @@
* fix hardlink check (null dereference in error message, segfaults
on solaris - noticed by Bob Bloom)
* sh_suidcheck: don't truncate quarantined file if nlink > 1
- * fix Install.sh (no --seperate-output with --radiolist); patch by
+ * fix Install.sh (no --separate-output with --radiolist); patch by
Greg Kimberly
1.8.4 (17-03-2004):