summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:08 +0000
commit7a2201963d5b03bd1828d350ccaecb4eda30d30c (patch)
tree19effbe90b8d78fdcb5f7d4bd0dd46b177ffdaab /.pre-commit-config.yaml
parentReleasing debian version 10.2.9-1. (diff)
downloadsqlglot-7a2201963d5b03bd1828d350ccaecb4eda30d30c.tar.xz
sqlglot-7a2201963d5b03bd1828d350ccaecb4eda30d30c.zip
Merging upstream version 10.4.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml31
1 files changed, 31 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 0000000..17ffb61
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,31 @@
+repos:
+ - repo: local
+ hooks:
+ - id: autoflake
+ name: autoflake
+ entry: autoflake -i -r
+ language: system
+ types: [ python ]
+ require_serial: true
+ files: ^(sqlglot/|tests/|setup.py)
+ - id: isort
+ name: isort
+ entry: isort
+ language: system
+ types: [ python ]
+ files: ^(sqlglot/|tests/|setup.py)
+ require_serial: true
+ - id: black
+ name: black
+ entry: black --line-length 100
+ language: system
+ types: [ python ]
+ require_serial: true
+ files: ^(sqlglot/|tests/|setup.py)
+ - id: mypy
+ name: mypy
+ entry: mypy
+ language: system
+ types: [ python ]
+ files: ^(sqlglot/|tests/)
+ require_serial: true