summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-02-08 05:38:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-02-08 05:38:42 +0000
commitc66e4a33e1a07c439f03fe47f146a6c6482bf6df (patch)
treecfdf01111c063b3e50841695e6c2768833aea4dc /.pre-commit-config.yaml
parentReleasing debian version 20.11.0-1. (diff)
downloadsqlglot-c66e4a33e1a07c439f03fe47f146a6c6482bf6df.tar.xz
sqlglot-c66e4a33e1a07c439f03fe47f146a6c6482bf6df.zip
Merging upstream version 21.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml37
1 files changed, 18 insertions, 19 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 51be787..52425a1 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,28 +1,27 @@
repos:
- repo: local
hooks:
- - id: autoflake
- name: autoflake
- entry: autoflake -i -r
- language: system
- types: [ python ]
+ - id: ruff
+ name: ruff
+ description: "Run 'ruff' for extremely fast Python linting"
+ entry: ruff check
+ --force-exclude --fix
+ --ignore E721
+ --ignore E741
+ language: python
+ types_or: [python, pyi]
require_serial: true
+ additional_dependencies: []
files: ^(sqlglot/|tests/|setup.py)
- - id: isort
- args: [--combine-as]
- name: isort
- entry: isort
- language: system
- types: [ python ]
- files: ^(sqlglot/|tests/|setup.py)
+ - id: ruff-format
+ name: ruff-format
+ description: "Run 'ruff format' for extremely fast Python formatting"
+ entry: ruff format
+ --force-exclude
+ --line-length 100
+ language: python
+ types_or: [python, pyi]
require_serial: true
- - id: black
- name: black
- entry: black --line-length 100
- language: system
- types: [ python ]
- require_serial: true
- files: ^(sqlglot/|tests/|setup.py)
- id: mypy
name: mypy
entry: mypy sqlglot tests