summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-19 11:01:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-19 11:01:55 +0000
commitf1c2dbe3b17a0d5edffbb65b85b642d0bb2756c5 (patch)
tree5dce0fe2a11381761496eb973c20750f44db56d5 /Makefile
parentReleasing debian version 20.1.0-1. (diff)
downloadsqlglot-f1c2dbe3b17a0d5edffbb65b85b642d0bb2756c5.tar.xz
sqlglot-f1c2dbe3b17a0d5edffbb65b85b642d0bb2756c5.zip
Merging upstream version 20.3.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index dcb02ad..521d302 100644
--- a/Makefile
+++ b/Makefile
@@ -3,22 +3,36 @@
install:
pip install -e .
-install-dev:
+install-dev-rs-release:
+ cd sqlglotrs/ && python -m maturin develop -r
+
+install-dev-rs:
+ cd sqlglotrs/ && python -m maturin develop
+
+install-dev-core:
pip install -e ".[dev]"
+install-dev: install-dev-core install-dev-rs
+
install-pre-commit:
pre-commit install
test:
- python -m unittest
+ SQLGLOTRS_TOKENIZER=0 python -m unittest
+
+test-rs:
+ RUST_BACKTRACE=1 python -m unittest
unit:
- SKIP_INTEGRATION=1 python -m unittest
+ SKIP_INTEGRATION=1 SQLGLOTRS_TOKENIZER=0 python -m unittest
+
+unit-rs:
+ SKIP_INTEGRATION=1 RUST_BACKTRACE=1 python -m unittest
style:
pre-commit run --all-files
-check: style test
+check: style test test-rs
docs:
python pdoc/cli.py -o docs