summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-15 16:46:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-15 16:46:17 +0000
commit28cc22419e32a65fea2d1678400265b8cabc3aff (patch)
treeff9ac1991fd48490b21ef6aa9015a347a165e2d9 /setup.py
parentInitial commit. (diff)
downloadsqlglot-28cc22419e32a65fea2d1678400265b8cabc3aff.tar.xz
sqlglot-28cc22419e32a65fea2d1678400265b8cabc3aff.zip
Adding upstream version 6.0.4.upstream/6.0.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..4803b7e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+from setuptools import find_packages, setup
+
+version = (
+ open("sqlglot/__init__.py")
+ .read()
+ .split("__version__ = ")[-1]
+ .split("\n")[0]
+ .strip("")
+ .strip("'")
+ .strip('"')
+)
+
+setup(
+ name="sqlglot",
+ version=version,
+ description="An easily customizable SQL parser and transpiler",
+ long_description=open("README.md").read(),
+ long_description_content_type="text/markdown",
+ url="https://github.com/tobymao/sqlglot",
+ author="Toby Mao",
+ author_email="toby.mao@gmail.com",
+ license="MIT",
+ packages=find_packages(include=["sqlglot", "sqlglot.*"]),
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "Intended Audience :: Science/Research",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: SQL",
+ "Programming Language :: Python :: 3 :: Only",
+ ],
+)