summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:08 +0000
commit7a2201963d5b03bd1828d350ccaecb4eda30d30c (patch)
tree19effbe90b8d78fdcb5f7d4bd0dd46b177ffdaab /setup.py
parentReleasing debian version 10.2.9-1. (diff)
downloadsqlglot-7a2201963d5b03bd1828d350ccaecb4eda30d30c.tar.xz
sqlglot-7a2201963d5b03bd1828d350ccaecb4eda30d30c.zip
Merging upstream version 10.4.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f1c4f9b..2c0a3be 100644
--- a/setup.py
+++ b/setup.py
@@ -22,6 +22,20 @@ setup(
license="MIT",
packages=find_packages(include=["sqlglot", "sqlglot.*"]),
package_data={"sqlglot": ["py.typed"]},
+ extras_require={
+ "dev": [
+ "autoflake",
+ "black",
+ "duckdb",
+ "isort",
+ "mypy",
+ "pandas",
+ "pyspark",
+ "python-dateutil",
+ "pdoc",
+ "pre-commit",
+ ],
+ },
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",