summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-02-08 05:38:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-02-08 05:38:42 +0000
commitc66e4a33e1a07c439f03fe47f146a6c6482bf6df (patch)
treecfdf01111c063b3e50841695e6c2768833aea4dc /setup.py
parentReleasing debian version 20.11.0-1. (diff)
downloadsqlglot-c66e4a33e1a07c439f03fe47f146a6c6482bf6df.tar.xz
sqlglot-c66e4a33e1a07c439f03fe47f146a6c6482bf6df.zip
Merging upstream version 21.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 1e2cb92..ba18f64 100644
--- a/setup.py
+++ b/setup.py
@@ -29,16 +29,14 @@ setup(
python_requires=">=3.7",
extras_require={
"dev": [
- "autoflake",
- "black",
"duckdb>=0.6",
- "isort",
- "mypy>=0.990",
+ "mypy",
"pandas",
"pyspark",
"python-dateutil",
"pdoc",
"pre-commit",
+ "ruff",
"types-python-dateutil",
"typing_extensions",
"maturin>=1.4,<2.0",