summaryrefslogtreecommitdiffstats
path: root/sqlglotrs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-11 12:13:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-11 12:13:38 +0000
commite894f65cf8a2e3c88439e1b06d8542b969e2bc3f (patch)
treedb0e8e728b297f06d7ad5a6034e8110bae97297e /sqlglotrs
parentReleasing debian version 25.18.0-1. (diff)
downloadsqlglot-e894f65cf8a2e3c88439e1b06d8542b969e2bc3f.tar.xz
sqlglot-e894f65cf8a2e3c88439e1b06d8542b969e2bc3f.zip
Merging upstream version 25.20.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sqlglotrs')
-rw-r--r--sqlglotrs/Cargo.lock2
-rw-r--r--sqlglotrs/Cargo.toml3
-rw-r--r--sqlglotrs/pyproject.toml9
3 files changed, 12 insertions, 2 deletions
diff --git a/sqlglotrs/Cargo.lock b/sqlglotrs/Cargo.lock
index e1f914f..b95e6b9 100644
--- a/sqlglotrs/Cargo.lock
+++ b/sqlglotrs/Cargo.lock
@@ -188,7 +188,7 @@ checksum = "4dccd0940a2dcdf68d092b8cbab7dc0ad8fa938bf95787e1b916b0e3d0e8e970"
[[package]]
name = "sqlglotrs"
-version = "0.2.9"
+version = "0.2.12"
dependencies = [
"pyo3",
]
diff --git a/sqlglotrs/Cargo.toml b/sqlglotrs/Cargo.toml
index efd5eb7..a3e23df 100644
--- a/sqlglotrs/Cargo.toml
+++ b/sqlglotrs/Cargo.toml
@@ -1,7 +1,8 @@
[package]
name = "sqlglotrs"
-version = "0.2.9"
+version = "0.2.12"
edition = "2021"
+license = "MIT"
[lib]
name = "sqlglotrs"
diff --git a/sqlglotrs/pyproject.toml b/sqlglotrs/pyproject.toml
index 867cdcc..d84ee91 100644
--- a/sqlglotrs/pyproject.toml
+++ b/sqlglotrs/pyproject.toml
@@ -4,13 +4,22 @@ build-backend = "maturin"
[project]
name = "sqlglotrs"
+description = "An easily customizable SQL parser and transpiler"
requires-python = ">=3.7"
classifiers = [
"Programming Language :: Rust",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
+ "License :: OSI Approved :: MIT License",
+]
+authors = [
+ { name="Toby Mao", email="toby.mao@gmail.com" },
]
dynamic = ["version"]
+[project.urls]
+Homepage = "https://github.com/tobymao/sqlglot"
+Issues = "https://github.com/tobymao/sqlglot/issues"
+
[tool.maturin]
features = ["pyo3/extension-module"]