summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 134637b..dcb02ad 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-.PHONY: install install-dev install-pre-commit test style check docs docs-serve
+.PHONY: install install-dev install-pre-commit test unit style check docs docs-serve
install:
pip install -e .
@@ -12,6 +12,9 @@ install-pre-commit:
test:
python -m unittest
+unit:
+ SKIP_INTEGRATION=1 python -m unittest
+
style:
pre-commit run --all-files