summaryrefslogtreecommitdiffstats
path: root/docs/install.rst
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-16 09:09:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-16 09:09:35 +0000
commit0dfe1c9e2780469e3a4696e8fb3e6f717a7ebeb7 (patch)
treea0b651b55ea02e3b00bbc5eedba566fdd6bd7c08 /docs/install.rst
parentInitial commit. (diff)
downloadterminaltables-0dfe1c9e2780469e3a4696e8fb3e6f717a7ebeb7.tar.xz
terminaltables-0dfe1c9e2780469e3a4696e8fb3e6f717a7ebeb7.zip
Adding upstream version 3.1.0.upstream/3.1.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docs/install.rst')
-rw-r--r--docs/install.rst38
1 files changed, 38 insertions, 0 deletions
diff --git a/docs/install.rst b/docs/install.rst
new file mode 100644
index 0000000..ea0bfae
--- /dev/null
+++ b/docs/install.rst
@@ -0,0 +1,38 @@
+.. _install:
+
+============
+Installation
+============
+
+Getting started is pretty simple. The first step is to install the library.
+
+Pip Install
+===========
+
+The easiest way to get terminaltables is to use `pip <https://pip.pypa.io>`_. Simply run this command.
+
+.. code-block:: bash
+
+ pip install terminaltables
+
+Latest from GitHub
+==================
+
+You can also elect to install the latest bleeding-edge version by using pip to install directly from the GitHub
+repository.
+
+.. code-block:: bash
+
+ pip install git+https://github.com/Robpol86/terminaltables.git
+
+Clone and Install
+=================
+
+Lastly you can also just clone the repo and install from it. Usually you only need to do this if you plan on
+`contributing <https://github.com/Robpol86/terminaltables/blob/master/CONTRIBUTING.md>`_ to the project.
+
+.. code-block:: bash
+
+ git clone https://github.com/Robpol86/terminaltables.git
+ cd terminaltables
+ python setup.py install