summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 1 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 11d33f8..2dd20cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,11 +20,4 @@ override_dh_compress:
dh_compress -X example1.py -X example2.py -X example3.py -X html/
override_dh_installchangelogs:
- # Trim the changelog section out of the README file. Note that this will
- # hang if the changelog-section-{start,end} strings don't appear exactly as
- # they are in the README file.
- python3 -c "with open('README.rst', encoding='utf-8') as r: print(''.join( \
- ['' for x in iter(r.readline, '.. changelog-section-start\n')] + \
- [x for x in iter(r.readline, '.. changelog-section-end\n')]))" \
- > debian/upstream-changelog
- dh_installchangelogs debian/upstream-changelog
+ dh_installchangelogs CHANGELOG.md