summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..723b783
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,21 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+CLEANFILES = *.gcda *.gcno *.gcov
+
+EXTRA_DIST =
+
+SUBDIRS = test
+
+lib_LTLIBRARIES = libtinyframe.la
+
+libtinyframe_la_SOURCES = tinyframe.c
+nobase_include_HEADERS = tinyframe/tinyframe.h
+nobase_nodist_include_HEADERS = tinyframe/version.h
+libtinyframe_la_LDFLAGS = -version-info $(TINYFRAME_LIBRARY_VERSION)
+EXTRA_DIST += tinyframe/version.h.in
+
+if ENABLE_GCOV
+gcov-local:
+ for src in $(libtinyframe_la_SOURCES); do \
+ gcov -l -r -s "$(srcdir)" "$$src"; \
+ done
+endif