summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-02 08:25:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-02 08:25:08 +0000
commitd7f67a741417e84c1106ff7f7d35d0968f56aba4 (patch)
tree27ee221971a079ec58aa5b67852015bee61751d6 /.pre-commit-config.yaml
parentAdding debian version 4.64.1-4. (diff)
downloadtqdm-d7f67a741417e84c1106ff7f7d35d0968f56aba4.tar.xz
tqdm-d7f67a741417e84c1106ff7f7d35d0968f56aba4.zip
Merging upstream version 4.66.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml12
1 files changed, 6 insertions, 6 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 95b4a82..4de1025 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -2,7 +2,7 @@ default_language_version:
python: python3
repos:
- repo: https://github.com/pre-commit/pre-commit-hooks
- rev: v4.1.0
+ rev: v4.5.0
hooks:
- id: check-added-large-files
- id: check-case-conflict
@@ -38,8 +38,8 @@ repos:
- pandas
- pytest-timeout
- pytest-asyncio
-- repo: https://gitlab.com/pycqa/flake8
- rev: 3.9.2
+- repo: https://github.com/PyCQA/flake8
+ rev: 7.0.0
hooks:
- id: flake8
args: [-j8]
@@ -49,14 +49,14 @@ repos:
- flake8-comprehensions
- flake8-debugger
- flake8-isort
+ - flake8-pyproject
- flake8-string-format
- - flake8-type-annotations
- repo: https://github.com/PyCQA/isort
- rev: 5.10.1
+ rev: 5.13.2
hooks:
- id: isort
- repo: https://github.com/kynan/nbstripout
- rev: 0.5.0
+ rev: 0.7.1
hooks:
- id: nbstripout
args: [--keep-count, --keep-output]