summaryrefslogtreecommitdiffstats
path: root/recipe
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-05-11 08:46:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-05-11 08:46:20 +0000
commit60b8ecaf2afb874b733c1c61be26da68df51d989 (patch)
tree8888727f276e44d23fc64b6b285dc00150a7a466 /recipe
parentInitial commit. (diff)
downloadtreelib-60b8ecaf2afb874b733c1c61be26da68df51d989.tar.xz
treelib-60b8ecaf2afb874b733c1c61be26da68df51d989.zip
Adding upstream version 1.6.4.upstream/1.6.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'recipe')
-rw-r--r--recipe/conda_build.sh33
-rw-r--r--recipe/meta.yaml25
2 files changed, 58 insertions, 0 deletions
diff --git a/recipe/conda_build.sh b/recipe/conda_build.sh
new file mode 100644
index 0000000..9cf439b
--- /dev/null
+++ b/recipe/conda_build.sh
@@ -0,0 +1,33 @@
+export VERSION="1.5.3"
+export BUILD_NAME="0"
+export CONDA_BLD_PATH=~/conda-bld
+USER="e3sm"
+PLATFORM="noarch"
+PKG="treelib"
+
+if [ -d $CONDA_BLD_PATH ]; then
+ rm -rf $CONDA_BLD_PATH
+fi
+echo "Creating build dir at" $CONDA_BLD_PATH
+mkdir $CONDA_BLD_PATH
+
+conda config --set anaconda_upload no
+if [ ! -z "$1" ]; then
+ export TAG="$1"
+else
+ export TAG="master"
+fi
+echo "Building" $VERSION"-"$BUILD_NAME "for label:" $TAG
+
+conda build .
+
+if [ $? -eq 1 ]; then
+ echo "conda build failed"
+ exit
+fi
+
+if [ ! -z "$1" ]; then
+ anaconda upload -u $USER -l "$1" $CONDA_BLD_PATH/$PLATFORM/$PKG-$VERSION-$BUILD_NAME.tar.bz2
+else
+ anaconda upload -u $USER $CONDA_BLD_PATH/$PLATFORM/$PKG-$VERSION-$BUILD_NAME.tar.bz2
+fi
diff --git a/recipe/meta.yaml b/recipe/meta.yaml
new file mode 100644
index 0000000..7dad9ac
--- /dev/null
+++ b/recipe/meta.yaml
@@ -0,0 +1,25 @@
+package:
+ name: treelib
+ version: {{ environ['VERSION'] }}
+
+source:
+ git_url: git://github.com/caesar0301/treelib.git
+ git_tag: {{ environ['TAG'] }}
+
+build:
+ script: python setup.py install
+ string: {{ environ['BUILD_NAME'] }}
+ noarch: python
+
+about:
+ home: https://treelib.readthedocs.io/en/latest/
+ summary: An efficient implementation of tree data structure in python 2/3.
+
+requirements:
+ build:
+ - python
+ - setuptools
+ - pip
+
+ run:
+ - python