summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-21 09:24:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-21 09:24:59 +0000
commit2bbf7ca3ab74b2e3a9b2e361fe56aeac1e2f4867 (patch)
tree6d0ad563f29e8b130a876da955b3174e40defed3 /CMakeLists.txt
parentReleasing debian version 1.7.1-1. (diff)
downloadttyd-2bbf7ca3ab74b2e3a9b2e361fe56aeac1e2f4867.tar.xz
ttyd-2bbf7ca3ab74b2e3a9b2e361fe56aeac1e2f4867.zip
Merging upstream version 1.7.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 919c983..85f8bdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,11 +4,11 @@ if(${CMAKE_VERSION} VERSION_LESS "3.12.0")
project(ttyd C)
set(PROJECT_VERSION_MAJOR "1")
set(PROJECT_VERSION_MINOR "7")
- set(PROJECT_VERSION_PATCH "1")
+ set(PROJECT_VERSION_PATCH "2")
set(PROJECT_VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
else()
cmake_policy(SET CMP0048 NEW)
- project(ttyd VERSION 1.7.1 LANGUAGES C)
+ project(ttyd VERSION 1.7.2 LANGUAGES C)
endif()
find_package(Git)
@@ -82,8 +82,11 @@ if(WIN32)
list(APPEND LINK_LIBS shell32 ws2_32)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/app.rc.in ${CMAKE_CURRENT_BINARY_DIR}/app.rc @ONLY)
list(APPEND SOURCE_FILES ${CMAKE_CURRENT_BINARY_DIR}/app.rc)
-elseif(NOT APPLE)
- list(APPEND LINK_LIBS util)
+else()
+ find_library(LIBUTIL NAMES util)
+ if(LIBUTIL)
+ list(APPEND LINK_LIBS util)
+ endif()
endif()
add_executable(${PROJECT_NAME} ${SOURCE_FILES})