summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-02 08:36:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-02 08:36:04 +0000
commit923d02b2c6d6fe489386521f3c269086d24db94d (patch)
treeceff315eb2159e44c893f15f718a8b2d6abd7782 /CMakeLists.txt
parentReleasing debian version 1.7.0-1. (diff)
downloadttyd-923d02b2c6d6fe489386521f3c269086d24db94d.tar.xz
ttyd-923d02b2c6d6fe489386521f3c269086d24db94d.zip
Merging upstream version 1.7.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa0d4e4..919c983 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,15 @@
cmake_minimum_required(VERSION 2.8)
-project(ttyd C)
-set(PROJECT_VERSION "1.7.0")
+if(${CMAKE_VERSION} VERSION_LESS "3.12.0")
+ project(ttyd C)
+ set(PROJECT_VERSION_MAJOR "1")
+ set(PROJECT_VERSION_MINOR "7")
+ set(PROJECT_VERSION_PATCH "1")
+ set(PROJECT_VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
+else()
+ cmake_policy(SET CMP0048 NEW)
+ project(ttyd VERSION 1.7.1 LANGUAGES C)
+endif()
find_package(Git)
if(GIT_FOUND)
@@ -72,6 +80,8 @@ endif()
if(WIN32)
list(APPEND LINK_LIBS shell32 ws2_32)
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/app.rc.in ${CMAKE_CURRENT_BINARY_DIR}/app.rc @ONLY)
+ list(APPEND SOURCE_FILES ${CMAKE_CURRENT_BINARY_DIR}/app.rc)
elseif(NOT APPLE)
list(APPEND LINK_LIBS util)
endif()