summaryrefslogtreecommitdiffstats
path: root/pygtk/Makefile.am.inc
diff options
context:
space:
mode:
Diffstat (limited to 'pygtk/Makefile.am.inc')
-rw-r--r--pygtk/Makefile.am.inc24
1 files changed, 24 insertions, 0 deletions
diff --git a/pygtk/Makefile.am.inc b/pygtk/Makefile.am.inc
new file mode 100644
index 0000000..033d601
--- /dev/null
+++ b/pygtk/Makefile.am.inc
@@ -0,0 +1,24 @@
+pyexec_LTLIBRARIES += pygtk/zbarpygtk.la
+pygtk_zbarpygtk_la_CPPFLAGS = \
+ $(GTK_CFLAGS) $(PYTHON_CFLAGS) $(PYGTK_CFLAGS) $(AM_CPPFLAGS)
+pygtk_zbarpygtk_la_LDFLAGS = -shared -module -avoid-version -export-dynamic \
+ -export-symbols-regex initzbarpygtk $(PYTHON_LDFLAGS)
+pygtk_zbarpygtk_la_LIBADD = \
+ $(PYGTK_LIBS) gtk/libzbargtk.la $(AM_LIBADD)
+
+pygtk_zbarpygtk_la_DEPENDENCIES = gtk/libzbargtk.la
+dist_pygtk_zbarpygtk_la_SOURCES = pygtk/zbarpygtkmodule.c
+nodist_pygtk_zbarpygtk_la_SOURCES = pygtk/zbarpygtk.c
+BUILT_SOURCES += pygtk/zbarpygtk.c pygtk/zbarpygtk.defs
+CLEANFILES += pygtk/zbarpygtk.c pygtk/zbarpygtk.defs
+EXTRA_DIST += pygtk/zbarpygtk.override
+
+# FIXME ugly hack to fixup new name... now non-standard?
+pygtk/zbarpygtk.defs: include/zbar/zbargtk.h
+ $(PYTHON) $(PYGTK_H2DEF) $< | \
+ $(SED) -e 's/Z_TYPE_BAR_/ZBAR_TYPE_/' > $@
+
+pygtk/%.c: pygtk/%.defs $(srcdir)/pygtk/zbarpygtk.override
+ $(PYGTK_CODEGEN) --prefix zbarpygtk \
+ --register $(PYGTK_DEFS)/gdk-types.defs \
+ --override $(srcdir)/pygtk/zbarpygtk.override $< > $@