summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am.inc
diff options
context:
space:
mode:
Diffstat (limited to 'python/Makefile.am.inc')
-rw-r--r--python/Makefile.am.inc13
1 files changed, 13 insertions, 0 deletions
diff --git a/python/Makefile.am.inc b/python/Makefile.am.inc
new file mode 100644
index 0000000..f1f30a4
--- /dev/null
+++ b/python/Makefile.am.inc
@@ -0,0 +1,13 @@
+pyexec_LTLIBRARIES += python/zbar.la
+python_zbar_la_CPPFLAGS = $(PYTHON_CFLAGS) $(AM_CPPFLAGS)
+python_zbar_la_LDFLAGS = -shared -module -avoid-version -export-dynamic \
+ -export-symbols-regex '(initzbar|PyInit_zbar)' $(PYTHON_LDFLAGS)
+python_zbar_la_LIBADD = zbar/libzbar.la $(AM_LIBADD)
+
+python_zbar_la_SOURCES = python/zbarmodule.c python/zbarmodule.h \
+ python/enum.c python/exception.c python/symbol.c python/symbolset.c \
+ python/symboliter.c python/image.c \
+ python/processor.c python/imagescanner.c python/decoder.c python/scanner.c
+
+EXTRA_DIST += python/test/barcode.png python/test/test_zbar.py \
+ python/examples/processor.py python/examples/read_one.py