summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-08 04:40:35 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-08 04:40:35 +0000
commitf7deb94049481143ef12eab590840d39aecedc14 (patch)
tree9ff4090b78d8343fd073ba1ea32068bb0d07caa6 /Makefile.in
parentAdding debian version 1.3-4. (diff)
downloadzutils-f7deb94049481143ef12eab590840d39aecedc14.tar.xz
zutils-f7deb94049481143ef12eab590840d39aecedc14.zip
Merging upstream version 1.4~pre2.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in69
1 files changed, 46 insertions, 23 deletions
diff --git a/Makefile.in b/Makefile.in
index f445454..0b7a4d0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -19,20 +19,22 @@ programs = zcat zcmp zdiff zgrep ztest zupdate
scripts = zegrep zfgrep
-.PHONY : all install install-bin install-info install-man install-strip \
+.PHONY : all install install-bin install-info install-man \
+ install-strip install-compress install-strip-compress \
+ install-bin-strip install-info-compress install-man-compress \
uninstall uninstall-bin uninstall-info uninstall-man \
doc info man check dist clean distclean
all : $(programs) $(scripts)
zcat : $(zcat_objs)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(zcat_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(zcat_objs)
zcmp : $(zcmp_objs)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(zcmp_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(zcmp_objs)
zdiff : $(zdiff_objs)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(zdiff_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(zdiff_objs)
zegrep : zegrep.in
cat $(VPATH)/zegrep.in > $@
@@ -43,34 +45,34 @@ zfgrep : zfgrep.in
chmod a+x zfgrep
zgrep : $(zgrep_objs)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(zgrep_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(zgrep_objs)
ztest : $(ztest_objs)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(ztest_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(ztest_objs)
zupdate : $(zupdate_objs)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(zupdate_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(zupdate_objs)
rc.o : rc.cc
- $(CXX) $(CXXFLAGS) $(CPPFLAGS) -DPROGVERSION=\"$(pkgversion)\" -DSYSCONFDIR=\"$(sysconfdir)\" -c -o $@ $<
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -DPROGVERSION=\"$(pkgversion)\" -DSYSCONFDIR=\"$(sysconfdir)\" -c -o $@ $<
zdiff.o : zdiff.cc
- $(CXX) $(CXXFLAGS) $(CPPFLAGS) -DDIFF=\"$(DIFF)\" -c -o $@ $<
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -DDIFF=\"$(DIFF)\" -c -o $@ $<
zgrep.o : zgrep.cc
- $(CXX) $(CXXFLAGS) $(CPPFLAGS) -DGREP=\"$(GREP)\" -c -o $@ $<
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -DGREP=\"$(GREP)\" -c -o $@ $<
%.o : %.cc
- $(CXX) $(CXXFLAGS) $(CPPFLAGS) -c -o $@ $<
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c -o $@ $<
$(objs) : Makefile
$(scripts) : Makefile
arg_parser.o : arg_parser.h
rc.o : arg_parser.h rc.h
-zcat.o : arg_parser.h rc.h zutils.h recursive.cc
+zcat.o : arg_parser.h rc.h zutils.h recursive.cc zcatgrep.cc
zcmp.o : arg_parser.h rc.h zutils.h zcmpdiff.cc
zdiff.o : arg_parser.h rc.h zutils.h zcmpdiff.cc
-zgrep.o : arg_parser.h rc.h zutils.h recursive.cc
+zgrep.o : arg_parser.h rc.h zutils.h recursive.cc zcatgrep.cc
ztest.o : arg_parser.h rc.h zutils.h recursive.cc
zupdate.o : arg_parser.h rc.h recursive.cc
zutils.o : rc.h zutils.h
@@ -117,6 +119,9 @@ check : all
@$(VPATH)/testsuite/check.sh $(VPATH)/testsuite $(pkgversion)
install : install-bin install-info install-man
+install-strip : install-bin-strip install-info install-man
+install-compress : install-bin install-info-compress install-man-compress
+install-strip-compress : install-bin-strip install-info-compress install-man-compress
install-bin : all
if [ ! -d "$(DESTDIR)$(bindir)" ] ; then $(INSTALL_DIR) "$(DESTDIR)$(bindir)" ; fi
@@ -133,13 +138,26 @@ install-bin : all
$(INSTALL_DATA) $(VPATH)/$(pkgname)rc "$(DESTDIR)$(sysconfdir)/$(pkgname)rc" ; \
fi
+install-bin-strip : all
+ $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install-bin
+
install-info :
if [ ! -d "$(DESTDIR)$(infodir)" ] ; then $(INSTALL_DIR) "$(DESTDIR)$(infodir)" ; fi
+ -rm -f "$(DESTDIR)$(infodir)/$(pkgname).info"*
$(INSTALL_DATA) $(VPATH)/doc/$(pkgname).info "$(DESTDIR)$(infodir)/$(pkgname).info"
-install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$(pkgname).info"
+install-info-compress : install-info
+ lzip -v -9 "$(DESTDIR)$(infodir)/$(pkgname).info"
+
install-man :
if [ ! -d "$(DESTDIR)$(mandir)/man1" ] ; then $(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1" ; fi
+ -rm -f "$(DESTDIR)$(mandir)/man1/zcat.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zcmp.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zdiff.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zgrep.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/ztest.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zupdate.1"*
$(INSTALL_DATA) $(VPATH)/doc/zcat.1 "$(DESTDIR)$(mandir)/man1/zcat.1"
$(INSTALL_DATA) $(VPATH)/doc/zcmp.1 "$(DESTDIR)$(mandir)/man1/zcmp.1"
$(INSTALL_DATA) $(VPATH)/doc/zdiff.1 "$(DESTDIR)$(mandir)/man1/zdiff.1"
@@ -147,10 +165,15 @@ install-man :
$(INSTALL_DATA) $(VPATH)/doc/ztest.1 "$(DESTDIR)$(mandir)/man1/ztest.1"
$(INSTALL_DATA) $(VPATH)/doc/zupdate.1 "$(DESTDIR)$(mandir)/man1/zupdate.1"
-install-strip : all
- $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install
+install-man-compress : install-man
+ lzip -v -9 "$(DESTDIR)$(mandir)/man1/zcat.1"
+ lzip -v -9 "$(DESTDIR)$(mandir)/man1/zcmp.1"
+ lzip -v -9 "$(DESTDIR)$(mandir)/man1/zdiff.1"
+ lzip -v -9 "$(DESTDIR)$(mandir)/man1/zgrep.1"
+ lzip -v -9 "$(DESTDIR)$(mandir)/man1/ztest.1"
+ lzip -v -9 "$(DESTDIR)$(mandir)/man1/zupdate.1"
-uninstall : uninstall-bin uninstall-info uninstall-man
+uninstall : uninstall-man uninstall-info uninstall-bin
uninstall-bin :
-rm -f "$(DESTDIR)$(bindir)/zcat"
@@ -165,15 +188,15 @@ uninstall-bin :
uninstall-info :
-install-info --info-dir="$(DESTDIR)$(infodir)" --remove "$(DESTDIR)$(infodir)/$(pkgname).info"
- -rm -f "$(DESTDIR)$(infodir)/$(pkgname).info"
+ -rm -f "$(DESTDIR)$(infodir)/$(pkgname).info"*
uninstall-man :
- -rm -f "$(DESTDIR)$(mandir)/man1/zcat.1"
- -rm -f "$(DESTDIR)$(mandir)/man1/zcmp.1"
- -rm -f "$(DESTDIR)$(mandir)/man1/zdiff.1"
- -rm -f "$(DESTDIR)$(mandir)/man1/zgrep.1"
- -rm -f "$(DESTDIR)$(mandir)/man1/ztest.1"
- -rm -f "$(DESTDIR)$(mandir)/man1/zupdate.1"
+ -rm -f "$(DESTDIR)$(mandir)/man1/zcat.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zcmp.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zdiff.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zgrep.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/ztest.1"*
+ -rm -f "$(DESTDIR)$(mandir)/man1/zupdate.1"*
dist : doc
ln -sf $(VPATH) $(DISTNAME)