summaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-08 04:19:00 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-08 04:19:00 +0000
commit67258f475f17f3824c5715eaa4ebdfee86f20142 (patch)
tree5281744f82f74ad6c3f79007052bb99bbf209b05 /configure
parentAdding debian version 0.8-1. (diff)
downloadzutils-67258f475f17f3824c5715eaa4ebdfee86f20142.tar.xz
zutils-67258f475f17f3824c5715eaa4ebdfee86f20142.zip
Merging upstream version 0.9~rc1.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure b/configure
index 2a45a9a..4d3753c 100755
--- a/configure
+++ b/configure
@@ -5,12 +5,12 @@
# This configure script is free software: you have unlimited permission
# to copy, distribute and modify it.
#
-# Date of this version: 2010-11-15
+# Date of this version: 2010-11-20
args=
no_create=
pkgname=zutils
-pkgversion=0.8
+pkgversion=0.9-rc1
progname=zutils
srctrigger=zutils.h
@@ -25,6 +25,8 @@ datadir='$(prefix)/share'
infodir='$(datadir)/info'
mandir='$(datadir)/man'
sysconfdir='$(prefix)/etc'
+DIFF=diff
+GREP=grep
if [ -n "${CXX}" ] ; then args="${args} CXX=\"${CXX}\"" ; fi
if [ -n "${CPPFLAGS}" ] ; then args="${args} CPPFLAGS=\"${CPPFLAGS}\"" ; fi
@@ -67,6 +69,8 @@ while [ -n "$1" ] ; do
echo " CPPFLAGS=OPTIONS command line options for the preprocessor [${CPPFLAGS}]"
echo " CXXFLAGS=OPTIONS command line options for the C++ compiler [${CXXFLAGS}]"
echo " LDFLAGS=OPTIONS command line options for the linker [${LDFLAGS}]"
+ echo " DIFF=NAME diff program to use with zdiff [diff]"
+ echo " GREP=NAME grep program to use with zgrep [grep]"
echo
exit 0 ;;
--version | --ve* | -V)
@@ -95,6 +99,8 @@ while [ -n "$1" ] ; do
CPPFLAGS=*) CPPFLAGS=${optarg} ;;
CXXFLAGS=*) CXXFLAGS=${optarg} ;;
LDFLAGS=*) LDFLAGS=${optarg} ;;
+ DIFF=*) DIFF=${optarg} ;;
+ GREP=*) GREP=${optarg} ;;
--* | *=* | *-*-*) ;;
*)
@@ -166,6 +172,8 @@ echo "CXX = ${CXX}"
echo "CPPFLAGS = ${CPPFLAGS}"
echo "CXXFLAGS = ${CXXFLAGS}"
echo "LDFLAGS = ${LDFLAGS}"
+echo "DIFF = ${DIFF}"
+echo "GREP = ${GREP}"
rm -f Makefile
cat > Makefile << EOF
# Makefile for Zutils - Utilities dealing with compressed files
@@ -190,6 +198,8 @@ CXX = ${CXX}
CPPFLAGS = ${CPPFLAGS}
CXXFLAGS = ${CXXFLAGS}
LDFLAGS = ${LDFLAGS}
+DIFF = ${DIFF}
+GREP = ${GREP}
EOF
cat ${srcdir}/Makefile.in >> Makefile