summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-08 04:40:05 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-08 04:40:05 +0000
commit168f04b9cec34039cca2afc2b2ae7394bc32fd8f (patch)
tree136d3bf73a953e3cf249cd8ce49f43ca4ad314a7 /debian/rules
parentAdding debian version 1.3-3. (diff)
downloadzutils-168f04b9cec34039cca2afc2b2ae7394bc32fd8f.tar.xz
zutils-168f04b9cec34039cca2afc2b2ae7394bc32fd8f.zip
Adding debian version 1.3-4.debian/1.3-4
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index d7cb7c9..2ec5912 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
%:
dh ${@} --parallel
@@ -16,7 +18,11 @@ override_dh_builddeb:
dh_builddeb -- -Zxz
override_dh_gencontrol:
+ifeq (kfreebsd,$(DEB_HOST_ARCH_OS))
+ dh_gencontrol -- -Vbuilt-using="glibc (= $$(dpkg-query --show --showformat='$${source:Version}' libc0.1-dev))"
+else
dh_gencontrol -- -Vbuilt-using="glibc (= $$(dpkg-query --show --showformat='$${source:Version}' libc6-dev))"
+endif
override_dh_strip:
dh_strip --dbg-package=zutils-dbg