summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/01-filename.patch54
-rw-r--r--debian/patches/series1
4 files changed, 64 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7cb1742..0936ed1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+zutils (0.9-6) unstable; urgency=low
+
+ * Adding patch from upstream to make filenames not prefixed to output by
+ default when searching one file (Closes: #694024).
+ * Updating to standards version 3.9.4.
+
+ -- Daniel Baumann <daniel.baumann@progress-technologies.net> Mon, 10 Dec 2012 11:23:06 +0100
+
zutils (0.9-5) unstable; urgency=low
* Using compression level 9 also for binary packages.
diff --git a/debian/control b/debian/control
index a2d923e..724fe02 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: utils
Priority: extra
Maintainer: Daniel Baumann <daniel.baumann@progress-technologies.net>
Build-Depends: debhelper (>= 9), lzip, texinfo
-Standards-Version: 3.9.3
+Standards-Version: 3.9.4
Homepage: http://www.nongnu.org/zutils/zutils.html
Package: zutils
diff --git a/debian/patches/01-filename.patch b/debian/patches/01-filename.patch
new file mode 100644
index 0000000..e78113e
--- /dev/null
+++ b/debian/patches/01-filename.patch
@@ -0,0 +1,54 @@
+Author: Antonio Diaz Diaz <ant_diaz@teleline.es>
+Description:
+ Make 'grep_show_name' tri-state so that file name is no prefixed to output by
+ default when searching one file.
+
+diff -Naurp zutils.orig/doc/zutils.info zutils/doc/zutils.info
+--- zutils.orig/doc/zutils.info 2012-12-10 11:18:56.507741935 +0100
++++ zutils/doc/zutils.info 2012-12-10 11:21:49.519773976 +0100
+@@ -389,7 +389,8 @@ matches were found, and 2 means trouble.
+
+ `-h'
+ `--no-filename'
+- Suppress the prefixing filename on output.
++ Suppress the prefixing of filenames on output when multiple files
++ are searched.
+
+ `-H'
+ `--with-filename'
+diff -Naurp zutils.orig/doc/zutils.texinfo zutils/doc/zutils.texinfo
+--- zutils.orig/doc/zutils.texinfo 2012-12-10 11:18:56.507741935 +0100
++++ zutils/doc/zutils.texinfo 2012-12-10 11:21:49.519773976 +0100
+@@ -432,7 +432,8 @@ Treat @var{pattern} as a set of newline-
+
+ @item -h
+ @itemx --no-filename
+-Suppress the prefixing filename on output.
++Suppress the prefixing of filenames on output when multiple files are
++searched.
+
+ @item -H
+ @itemx --with-filename
+diff -Naurp zutils.orig/main.cc zutils/main.cc
+--- zutils.orig/main.cc 2012-12-10 11:18:56.507741935 +0100
++++ zutils/main.cc 2012-12-10 11:21:49.519773976 +0100
+@@ -243,8 +243,8 @@ int main( const int argc, const char * c
+ return ( program_mode == m_zcat ) ? 1 : 2; }
+
+ int argind = 0;
++ int grep_show_name = -1;
+ bool grep_list = false;
+- bool grep_show_name = true;
+ bool grep_pattern_found = false;
+ for( ; argind < parser.arguments(); ++argind )
+ {
+@@ -350,6 +350,9 @@ int main( const int argc, const char * c
+
+ if( filenames.empty() ) filenames.push_back("-");
+
++ if( grep_show_name < 0 && filenames.size() == 1 )
++ grep_show_name = false;
++
+ int retval = ( ( program_mode == m_zgrep ) ? 1 : 0 );
+ while( !filenames.empty() )
+ {
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..46f3936
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+01-filename.patch