summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index fbd7102..b8984fd 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -66,6 +66,10 @@ zgrep.o : zgrep.cc
%.o : %.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c -o $@ $<
+# prevent 'make' from trying to remake source files
+$(VPATH)/configure $(VPATH)/Makefile.in $(VPATH)/doc/$(pkgname).texi : ;
+%.h %.cc : ;
+
$(objs) : Makefile
$(scripts) : Makefile
arg_parser.o : arg_parser.h
@@ -78,7 +82,6 @@ ztest.o : arg_parser.h rc.h zutils.h recursive.cc
zupdate.o : arg_parser.h rc.h recursive.cc
zutils.o : rc.h zutils.h
-
doc : info man
info : $(VPATH)/doc/$(pkgname).info
@@ -106,7 +109,7 @@ $(VPATH)/doc/zgrep.1 : zgrep
-o $@ --info-page=$(pkgname) ./zgrep
$(VPATH)/doc/ztest.1 : ztest
- help2man -n 'verify the integrity of compressed files' \
+ help2man -n 'check the integrity of compressed files' \
-o $@ --info-page=$(pkgname) ./ztest
$(VPATH)/doc/zupdate.1 : zupdate