summaryrefslogtreecommitdiffstats
path: root/tests/t305/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t305/Makefile')
-rw-r--r--tests/t305/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/t305/Makefile b/tests/t305/Makefile
new file mode 100644
index 0000000..1ee30fc
--- /dev/null
+++ b/tests/t305/Makefile
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+include ../common.mk
+clean: clean-common
+
+check:
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5a/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5b/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5c/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5d/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5e/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5f/DEBIAN/control
+ grep -Fxq dh_python3 debian/foo5a.debhelper.log.end_dh_install
+ grep -Fxc dh_python3 debian/foo5a.debhelper.log.end_dh_install | grep -Fxq 1