summaryrefslogtreecommitdiffstats
path: root/tests/t305
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t305')
-rw-r--r--tests/t305/Makefile14
-rw-r--r--tests/t305/debian/changelog5
-rw-r--r--tests/t305/debian/compat1
-rw-r--r--tests/t305/debian/control43
-rw-r--r--tests/t305/debian/copyright2
-rw-r--r--tests/t305/debian/foo5a.install1
-rw-r--r--tests/t305/debian/foo5b.install1
-rw-r--r--tests/t305/debian/foo5c.install1
-rw-r--r--tests/t305/debian/foo5d.install1
-rwxr-xr-xtests/t305/debian/rules22
-rw-r--r--tests/t305/debian/source/format1
-rwxr-xr-xtests/t305/foo5a2
-rwxr-xr-xtests/t305/foo5b2
-rwxr-xr-xtests/t305/foo5c2
-rwxr-xr-xtests/t305/foo5d2
15 files changed, 100 insertions, 0 deletions
diff --git a/tests/t305/Makefile b/tests/t305/Makefile
new file mode 100644
index 0000000..1ee30fc
--- /dev/null
+++ b/tests/t305/Makefile
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+include ../common.mk
+clean: clean-common
+
+check:
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5a/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5b/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5c/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5d/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5e/DEBIAN/control
+ grep -qe "Depends: .*python3\(:any\)\?" debian/foo5f/DEBIAN/control
+ grep -Fxq dh_python3 debian/foo5a.debhelper.log.end_dh_install
+ grep -Fxc dh_python3 debian/foo5a.debhelper.log.end_dh_install | grep -Fxq 1
diff --git a/tests/t305/debian/changelog b/tests/t305/debian/changelog
new file mode 100644
index 0000000..d30d06c
--- /dev/null
+++ b/tests/t305/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.0) unstable; urgency=low
+
+ * Initial release
+
+ -- Maximilian Engelhardt <maxi@daemonizer.de> Fri, 02 Apr 2021 14:30:25 +0200
diff --git a/tests/t305/debian/compat b/tests/t305/debian/compat
new file mode 100644
index 0000000..48082f7
--- /dev/null
+++ b/tests/t305/debian/compat
@@ -0,0 +1 @@
+12
diff --git a/tests/t305/debian/control b/tests/t305/debian/control
new file mode 100644
index 0000000..8eafc3e
--- /dev/null
+++ b/tests/t305/debian/control
@@ -0,0 +1,43 @@
+Source: foo
+Section: misc
+Priority: optional
+Maintainer: Maximilian Engelhardt <maxi@daemonizer.de>
+Build-Depends: debhelper (>= 12.9)
+Build-Depends-Indep: python3
+Standards-Version: 4.5.1
+
+Package: foo5a
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: example 5a - private shebangs
+ example package #5 - shebang related tests in private dirs
+
+Package: foo5b
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: example 5b - private shebangs
+ example package #5 - shebang related tests in private dirs
+
+Package: foo5c
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: example 5c - private shebangs
+ example package #5 - shebang related tests in private dirs
+
+Package: foo5d
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: example 5d - private shebangs
+ example package #5 - shebang related tests in private dirs
+
+Package: foo5e
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: example 5e - private shebangs
+ example package #5 - shebang related tests in private dirs
+
+Package: foo5f
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: example 5f - private shebangs
+ example package #5 - shebang related tests in private dirs
diff --git a/tests/t305/debian/copyright b/tests/t305/debian/copyright
new file mode 100644
index 0000000..32bbc0d
--- /dev/null
+++ b/tests/t305/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2021, Maximilian Engelhardt <maxi@daemonizer.de> and
+is licensed under the MIT License.
diff --git a/tests/t305/debian/foo5a.install b/tests/t305/debian/foo5a.install
new file mode 100644
index 0000000..38009bc
--- /dev/null
+++ b/tests/t305/debian/foo5a.install
@@ -0,0 +1 @@
+foo5a /usr/share/foo/
diff --git a/tests/t305/debian/foo5b.install b/tests/t305/debian/foo5b.install
new file mode 100644
index 0000000..0fd0869
--- /dev/null
+++ b/tests/t305/debian/foo5b.install
@@ -0,0 +1 @@
+foo5b /usr/share/foo/
diff --git a/tests/t305/debian/foo5c.install b/tests/t305/debian/foo5c.install
new file mode 100644
index 0000000..a40b010
--- /dev/null
+++ b/tests/t305/debian/foo5c.install
@@ -0,0 +1 @@
+foo5c /usr/share/foo/
diff --git a/tests/t305/debian/foo5d.install b/tests/t305/debian/foo5d.install
new file mode 100644
index 0000000..e6e2aea
--- /dev/null
+++ b/tests/t305/debian/foo5d.install
@@ -0,0 +1 @@
+foo5d /usr/share/foo/
diff --git a/tests/t305/debian/rules b/tests/t305/debian/rules
new file mode 100755
index 0000000..c43eaae
--- /dev/null
+++ b/tests/t305/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+%:
+ dh $@ --buildsystem=none
+
+override_dh_auto_install:
+ dh_auto_install
+ mkdir -p debian/foo5e/usr/share/foo/
+ echo "#! /usr/bin/env $(shell py3versions -d)\n\"/usr/bin/env DEFAULT_PYTHON shebang\"" > debian/foo5e/usr/share/foo/foo5e
+ chmod +x debian/foo5e/usr/share/foo/foo5e
+ mkdir -p debian/foo5f/usr/share/foo/
+ echo "#! /usr/bin/$(shell py3versions -d)\n\"/usr/bin/DEFAULT_PYTHON shebang\"" > debian/foo5f/usr/share/foo/foo5f
+ chmod +x debian/foo5f/usr/share/foo/foo5f
+
+override_dh_install:
+ dh_install
+ DH_VERBOSE=1 ../../dh_python3 -p foo5a /usr/share/foo
+ DH_VERBOSE=1 ../../dh_python3 --remaining-packages /usr/share/foo
+ cp debian/foo5a.debhelper.log debian/foo5a.debhelper.log.end_dh_install
+
+clean:
+ rm -f debian/foo5a.debhelper.log.end_dh_install
+ dh_clean
diff --git a/tests/t305/debian/source/format b/tests/t305/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/t305/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/t305/foo5a b/tests/t305/foo5a
new file mode 100755
index 0000000..3045ad0
--- /dev/null
+++ b/tests/t305/foo5a
@@ -0,0 +1,2 @@
+#! /usr/bin/python3
+"/usr/bin/python3 shebang"
diff --git a/tests/t305/foo5b b/tests/t305/foo5b
new file mode 100755
index 0000000..49352f5
--- /dev/null
+++ b/tests/t305/foo5b
@@ -0,0 +1,2 @@
+#! /usr/bin/python
+"/usr/bin/python shebang"
diff --git a/tests/t305/foo5c b/tests/t305/foo5c
new file mode 100755
index 0000000..2ee0891
--- /dev/null
+++ b/tests/t305/foo5c
@@ -0,0 +1,2 @@
+#! /usr/bin/env python3
+"/usr/bin/env python3 shebang"
diff --git a/tests/t305/foo5d b/tests/t305/foo5d
new file mode 100755
index 0000000..b698372
--- /dev/null
+++ b/tests/t305/foo5d
@@ -0,0 +1,2 @@
+#! /usr/bin/env python
+"/usr/bin/env python shebang"