summaryrefslogtreecommitdiffstats
path: root/tests/ta01/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ta01/Makefile')
-rw-r--r--tests/ta01/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/ta01/Makefile b/tests/ta01/Makefile
new file mode 100644
index 0000000..65c9796
--- /dev/null
+++ b/tests/ta01/Makefile
@@ -0,0 +1,39 @@
+all: run check
+
+run:
+ @echo No build needed
+ifeq ($(AUTOPKGTEST_TMP),)
+ @echo NOTE this test uses the system pybuild-autopkgtest, not the working directory
+endif
+
+check: pass fail
+
+pass:
+ @echo "=============================================================="
+ @echo "= pybuild-autopkgtest passes when tests pass ="
+ @echo "=============================================================="
+ @echo
+ pybuild-autopkgtest
+ test -f marker-before-pybuild-autopkgtest
+ test -f marker-after-pybuild-autopkgtest
+ grep '^1$$' marker-PYBUILD_AUTOPKGTEST
+ @echo '------------------------------'
+ @echo "OK: pybuild-autopkgtest passed"
+ @echo '------------------------------'
+ @echo
+
+fail:
+ @echo "=============================================================="
+ @echo "= pybuild-autopkgtest fails when tests fail ="
+ @echo "=============================================================="
+ @echo
+ ! FAILS=1 pybuild-autopkgtest
+ @echo '------------------------------'
+ @echo "OK: pybuild-autopkgtest failed"
+ @echo '------------------------------'
+ @echo
+
+clean:
+ifneq ($(AUTOPKGTEST_TMP),)
+ rm -r $(AUTOPKGTEST_TMP)/*
+endif