summaryrefslogtreecommitdiffstats
path: root/tests/ta01
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ta01')
-rw-r--r--tests/ta01/Makefile39
-rw-r--r--tests/ta01/debian/changelog5
-rw-r--r--tests/ta01/debian/control15
-rwxr-xr-xtests/ta01/debian/rules33
-rw-r--r--tests/ta01/foo/__init__.py1
-rw-r--r--tests/ta01/pyproject.toml3
-rw-r--r--tests/ta01/setup.cfg10
-rw-r--r--tests/ta01/tests/__init__.py0
-rw-r--r--tests/ta01/tests/test_foo.py7
9 files changed, 113 insertions, 0 deletions
diff --git a/tests/ta01/Makefile b/tests/ta01/Makefile
new file mode 100644
index 0000000..65c9796
--- /dev/null
+++ b/tests/ta01/Makefile
@@ -0,0 +1,39 @@
+all: run check
+
+run:
+ @echo No build needed
+ifeq ($(AUTOPKGTEST_TMP),)
+ @echo NOTE this test uses the system pybuild-autopkgtest, not the working directory
+endif
+
+check: pass fail
+
+pass:
+ @echo "=============================================================="
+ @echo "= pybuild-autopkgtest passes when tests pass ="
+ @echo "=============================================================="
+ @echo
+ pybuild-autopkgtest
+ test -f marker-before-pybuild-autopkgtest
+ test -f marker-after-pybuild-autopkgtest
+ grep '^1$$' marker-PYBUILD_AUTOPKGTEST
+ @echo '------------------------------'
+ @echo "OK: pybuild-autopkgtest passed"
+ @echo '------------------------------'
+ @echo
+
+fail:
+ @echo "=============================================================="
+ @echo "= pybuild-autopkgtest fails when tests fail ="
+ @echo "=============================================================="
+ @echo
+ ! FAILS=1 pybuild-autopkgtest
+ @echo '------------------------------'
+ @echo "OK: pybuild-autopkgtest failed"
+ @echo '------------------------------'
+ @echo
+
+clean:
+ifneq ($(AUTOPKGTEST_TMP),)
+ rm -r $(AUTOPKGTEST_TMP)/*
+endif
diff --git a/tests/ta01/debian/changelog b/tests/ta01/debian/changelog
new file mode 100644
index 0000000..322011c
--- /dev/null
+++ b/tests/ta01/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.2.3) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ozarowski <piotr@debian.org> Tue, 02 Jul 2013 11:02:06 +0200
diff --git a/tests/ta01/debian/control b/tests/ta01/debian/control
new file mode 100644
index 0000000..f8922fc
--- /dev/null
+++ b/tests/ta01/debian/control
@@ -0,0 +1,15 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper-compat (= 12)
+ , pybuild-plugin-pyproject
+ , python3-all
+ , python3-setuptools
+Standards-Version: 3.9.4
+
+Package: python3-foo
+Architecture: any
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #8
diff --git a/tests/ta01/debian/rules b/tests/ta01/debian/rules
new file mode 100755
index 0000000..e53f0aa
--- /dev/null
+++ b/tests/ta01/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build --verbose
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test
+
+override_dh_auto_clean:
+ ../../pybuild --clean --verbose
+ rm -rf .pybuild foo.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
+
+before-pybuild-autopkgtest:
+ echo $(PYBUILD_AUTOPKGTEST) > marker-PYBUILD_AUTOPKGTEST
+ touch marker-before-pybuild-autopkgtest
+
+after-pybuild-autopkgtest:
+ touch marker-after-pybuild-autopkgtest
diff --git a/tests/ta01/foo/__init__.py b/tests/ta01/foo/__init__.py
new file mode 100644
index 0000000..92d9a9a
--- /dev/null
+++ b/tests/ta01/foo/__init__.py
@@ -0,0 +1 @@
+"Nothing here"
diff --git a/tests/ta01/pyproject.toml b/tests/ta01/pyproject.toml
new file mode 100644
index 0000000..9787c3b
--- /dev/null
+++ b/tests/ta01/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
diff --git a/tests/ta01/setup.cfg b/tests/ta01/setup.cfg
new file mode 100644
index 0000000..877dcf7
--- /dev/null
+++ b/tests/ta01/setup.cfg
@@ -0,0 +1,10 @@
+[metadata]
+name = foo
+version = 0.1
+description = My package description
+long_description = My long description
+license = Expat
+
+[options]
+zip_safe = False
+packages = find:
diff --git a/tests/ta01/tests/__init__.py b/tests/ta01/tests/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/ta01/tests/__init__.py
diff --git a/tests/ta01/tests/test_foo.py b/tests/ta01/tests/test_foo.py
new file mode 100644
index 0000000..263a9fb
--- /dev/null
+++ b/tests/ta01/tests/test_foo.py
@@ -0,0 +1,7 @@
+import os
+import unittest
+
+class TestPybuildAutopkgtest(unittest.TestCase):
+
+ def test_pass_or_fails(self):
+ self.assertIsNone(os.environ.get("FAILS"))