summaryrefslogtreecommitdiffstats
path: root/src/lib-test/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
commitf7548d6d28c313cf80e6f3ef89aed16a19815df1 (patch)
treea3f6f2a3f247293bee59ecd28e8cd8ceb6ca064a /src/lib-test/Makefile.am
parentInitial commit. (diff)
downloaddovecot-f7548d6d28c313cf80e6f3ef89aed16a19815df1.tar.xz
dovecot-f7548d6d28c313cf80e6f3ef89aed16a19815df1.zip
Adding upstream version 1:2.3.19.1+dfsg1.upstream/1%2.3.19.1+dfsg1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/lib-test/Makefile.am')
-rw-r--r--src/lib-test/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/lib-test/Makefile.am b/src/lib-test/Makefile.am
new file mode 100644
index 0000000..ce7417d
--- /dev/null
+++ b/src/lib-test/Makefile.am
@@ -0,0 +1,20 @@
+noinst_LTLIBRARIES = libtest.la
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-charset
+
+libtest_la_SOURCES = \
+ fuzzer.c \
+ test-common.c \
+ test-istream.c \
+ test-ostream.c \
+ test-subprocess.c
+
+headers = \
+ fuzzer.h \
+ test-common.h \
+ test-subprocess.h
+
+pkginc_libdir=$(pkgincludedir)
+pkginc_lib_HEADERS = $(headers)